PSW125 Problems: Periodic Humming, Static and Heartbeat Noises

13»

Comments

  • ClipdatClipdat Posts: 7,280
    Stop spamming our forum.
    "Electronic music is human sound adapting to indulge technology, and for some, it feels like the signature sound of energy. New and abstract sounds over hypnotic rhythms can conjure vast soundscapes for escape, pleasure, and transcendence."
  • ClipdatClipdat Posts: 7,280
    ^^ Again, this was directed toward a spammer that was posting links for people to click on, not at anyone having a discussion in this thread.
    "Electronic music is human sound adapting to indulge technology, and for some, it feels like the signature sound of energy. New and abstract sounds over hypnotic rhythms can conjure vast soundscapes for escape, pleasure, and transcendence."
  • rvs007rvs007 Posts: 1
    Hi everyone, I started noticing the dreaded heartbeat noise a week or so ago with my PSW125. Found this thread when I was googling for a solution. I thought I was covered by the 5 year warranty (it was purchased in March 2014 from Best Buy Canada) but to my dismay, the amplifier is only covered for 3 years. Shameful that Polk Audio wouldn't cover all aspect of their product with the 5 year warranty. It's like they know the amplifier would fail first beyond 3 years.

    I see some older posts recommending to contact someone at soundunited.com? Is that still the course of action for Canadian customers? Moderator can you post the latest contact information for getting the heartbeat issue fixed?

    Thank you.
  • rooftop59rooftop59 Posts: 6,010
    Living Room 2.1: Dynaudio Contour 1.3mkii; Energy s10.2 sub; Cambridge Azur 851a; Cambridge Azur 752BD; Bryston BPD-1; NVidia ShieldTV
    Game Room HT: Denon AVR-X4200w; Definitive Technology SM350; Definitive Technology LCR2000; Definitive Technology Procinema 800; Mirage Nanasats; Sub - HSU VTF-2 MK5; LG UP870 4K BDP;
    ; Master Bedroom
    Cambridge Azur 551r; Definitive Technology SM45, ACI Titan Subwoofer Squeezebox Touch
  • Hi,
    I got Polk Subwoofer Model PSW125 and its not turning on.
    Initially Fuse got blown and replaced it .
    Now fuse is ok ,but the SubWoofer won't power on.
    Not sure on the issue.
    Any suggestions.
    Highly appreciated for your help.

    Thank you
    Arulcckprbzo7l5w.jpeg
  • affnaffaffnaff Posts: 1
    Hi, I have a similar issue. started about 6 years since purchased:

    If you want to listen to the sound. First 10 seconds is a low volume, last 10 seconds at higher volume.

    https://www.dropbox.com/s/j20xwkcoz4jtgrf/PWS125 Noise Inssue.mp3?dl=0

    Any help would be appreciated.

    Thanks,

    Nic
  • curglecurgle Posts: 1
    I have a PSW111 sub which has also begun making the heartbeat noise. Started infrequently but is now consistent and the sub is unusable. Seems this is a known issue???? What is the best course of action?

    I'm in Canada (Toronto).

    Appreciate any information or recommendations!
  • F1nutF1nut Posts: 43,106
    Try contacting the Canadian distributor for Polk to see if a replacement amp is available.
    Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a t-u-r-d by the clean end."


    President of Club Polk

  • stjen666stjen666 Posts: 1
    Hi, PSW125 makes all sorts of weird noises if powered up. No audio connections just power. Bought at future shop not sure when definitely more than 3 years serial number AM122511042. How do I get this fixed?
  • mfd4843mfd4843 Posts: 1
    Hi,
    I have a Polk PSW110. It started with the heartbeat sound about a week ago. Now I am also getting what I've heard referred to as a 60hz hum. The hum comes and goes, but the heartbeat sound is constant. It doesn't change in loudness if you turn the volume up or down. Is Polk doing anything for this, or is it just too late. Any information would be appreciated.
    Best regards,
    Michael
    5/21/2019
  • Hi there,

    I have a 3 year old psw125 with the exact same heart beat problem. The sub only seems to work when on max volumn and then even cuts in and out. I’m based in Australia. Are you able to please confirm who the best person is to contact and also if Polk has ended up doing any replacements free of charge due to the huge issue they have ? Thank you
  • chroschros Posts: 5
    edited September 23
    chros wrote: »
    Hey Guys! I started to have the very exact problem yesterday (mine is 1.5 years old), google lead me here. Reading the comments tells me that it's the amp, only 1 RCA cable is used for LFE from my Yamaha AVR. Noise isn't there only (!) if I unplug the power cable, otherwise it's always present:
    - when RCA cable is plugged off (means no input at all)
    - doesn't matter if the switch on the back is on/auto/standby mode
    - doesn't matter where the potmeters are set (lfe/volume)
    - doesn't matter where the phase switch is set

    So, after around 2 years later, the replacement amp board started to do the same thing around 2 months ago :(
    I tried to contact Gil again, but didn't get back any reply this time.
    blackice36 wrote: »
    Same issue with my psw125. Heartbeat for a few months, and now no output. Found a site describing 2 bad caps. Might try to follow his suggesting and repair myself. Polk wants $120 for a board. Caps are 50 cents each. Wish this was covered under the 5 year warranty. Shameful failure rate polk....

    http://mrfxr.com/polk-subwoofer/

    Thank you so much for the info!
    I ended up in a local repair shop, giving them the link you've posted plus the original amp board and asking them to replace only the 2 problematic capacitors with a better ones from the article (a lower ripple rate and longer lifetime). They just did and it works fine again for 2 days now. I can only hope that this time it will last around 5 years :)
    2019polk wrote: »
    I have a 3 year old psw125 with the exact same heart beat problem. The sub only seems to work when on max volumn and then even cuts in and out. I’m based in Australia. Are you able to please confirm who the best person is to contact and also if Polk has ended up doing any replacements free of charge due to the huge issue they have ? Thank you
    Can't you connect your retailer instead?
    I was surprised that you can't even buy a pws 125 anymore :) See above for the rest.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!