DSW Pro 440wi Power cord wiggles loose

My Polk DSW Pro 440wi power cord gets loose often shutting the subwoofer off. Guess I will have to tape it on somehow. More elegant solution?

Answers

  • ken brydsonken brydson Posts: 7,546
    jklangen99 wrote: »
    My Polk DSW Pro 440wi power cord gets loose often shutting the subwoofer off. Guess I will have to tape it on somehow. More elegant solution?

    Spread out the prongs...
    HT/Main- Panny 50" G10 Plasma, Pioneer SC-1222k AVR, Panny DMP-BD60 BDP, Polk LS90 mains, CS350LS center, LS/fx side surrounds, LS50 surround backs, SVS 25-31PC+ sub, Harmony One

    Office Rig- Marantz 2252B, Denon 2910, Kenwood KD2070 TT, Polk RTA 12B's/ RTA8t
  • gimpodgimpod Posts: 1,775
    Yes, one idea hard wire it.
    Pink Floyd, Just makes me want to turn it up too 12 and share it with the world!!. JMO
    ---
    “The two most important days in your life are the day you are born and the day you find out why.” ~ Mark Twain

    Unfortunately for most of us we only get to experience the first day and then we can't even remember it.
    ---
    "Close only counts in Horseshoes, Hand Grenades and Thermonuclear Weapons."
    "50% Why... That's almost half."
    "I know, I'm sick and need help."
    ----
    Gimpod Custom 4th & 5th Gen SDA Circuit Boards
    ----
    "The best way to enjoy digital music reproduction is to never listen to good analogue reproduction." ~ Kenneth Swauger
  • verbverb Posts: 7,911
    jklangen99 wrote: »
    My Polk DSW Pro 440wi power cord gets loose often shutting the subwoofer off. Guess I will have to tape it on somehow. More elegant solution?

    It's a friction fit, so a layer of electrical tape around the plug should do the trick. Elegance is preserved if you use black tape of course! :smile:
    Basement: Polk SDA SRS, Cary SLP-05 Pre, Enlightened Audio Designs CD Transport, Northstar Designs Excelsio DAC, Silnote Morpheus Ref2 Digital Cable, Marantz SA-14 SACD, McIntosh MC300 Amp, Furman 15PFi Power Conditioner, Pangea Power Cables, Wireworld Oasis 8 RCA IC's, MIT Shotgun S3 IC's, MIT Shotgun S1 Bi-Wire speaker cables
    Office: PC, EAR Acute CD Player, EAR 834L Pre, PASS ACA Monoblocks, Denon UDR-F10 Cassette, Acoustic Technologies Classic FR Speakers, SVS SB12 Plus sub, MIT AVt2 speaker cables, IFI Purifier2, AQ Cinnamon USB cable, Groneberg Quatro Reference IC's
    Spare Room: , Antique Sound Labs Wave AV-8 Monoblocks, Tisbury Mini Passive Pre, Tjoeb 99 tube CD player (modified Marantz CD-38), Analysis Plus Oval 9's, Zu Jumpers, AudioEngine B1 Streamer, Klipsch RB-61 v2, SVS PB1000 sub, Blue Jeans RCA IC's
    Living Room: Peachtree Nova Integrated, Cambridge CXN v2 Streamer, Furman 15PFi Power Conditioner, Polk RT265 In Wall Speakers, Polk DSW Pro 660wi sub
  • verbverb Posts: 7,911
    Oh, and welcome to CP! :smile:
    Basement: Polk SDA SRS, Cary SLP-05 Pre, Enlightened Audio Designs CD Transport, Northstar Designs Excelsio DAC, Silnote Morpheus Ref2 Digital Cable, Marantz SA-14 SACD, McIntosh MC300 Amp, Furman 15PFi Power Conditioner, Pangea Power Cables, Wireworld Oasis 8 RCA IC's, MIT Shotgun S3 IC's, MIT Shotgun S1 Bi-Wire speaker cables
    Office: PC, EAR Acute CD Player, EAR 834L Pre, PASS ACA Monoblocks, Denon UDR-F10 Cassette, Acoustic Technologies Classic FR Speakers, SVS SB12 Plus sub, MIT AVt2 speaker cables, IFI Purifier2, AQ Cinnamon USB cable, Groneberg Quatro Reference IC's
    Spare Room: , Antique Sound Labs Wave AV-8 Monoblocks, Tisbury Mini Passive Pre, Tjoeb 99 tube CD player (modified Marantz CD-38), Analysis Plus Oval 9's, Zu Jumpers, AudioEngine B1 Streamer, Klipsch RB-61 v2, SVS PB1000 sub, Blue Jeans RCA IC's
    Living Room: Peachtree Nova Integrated, Cambridge CXN v2 Streamer, Furman 15PFi Power Conditioner, Polk RT265 In Wall Speakers, Polk DSW Pro 660wi sub
  • So the black tape fixed the perceived problem of the power staying on. I say perceived because of the following. I am now seeing the unit go into standby mode in the Auto mode. It stays on in the On mode. I have the crossover set at 90Hz on the Yamaha 475 AV receiver. I have Polk TL350 5 speaker satellite / center. I can't detect the sub listening to a TV audio source. I could the other day listening to a dvd after wiggling the power cord. Of course, the setup is over 5 years old bought in 2013.
  • monepolkmonepolk Posts: 1,035
    I have found that dialogue heavy content may not have enough bass to keep my DSW 550 on when in the auto mode.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!