PSW505 light on rear not switching from red to green

Hi - My subwoofer PSW505 randomly stopped switching from standby to on mode. The sub does not turn green even if manually put on the On mode. There is distorted sound if played at a loud volume. On low volume there is No sound.

Any help much appreciated.

Best Answer

Answers

  • KennethSwaugerKennethSwauger Moderator Posts: 6,837
    Hello,
    Welcome to Polk's forum. In all likelihood the bass amplifier needs to be replaced or repaired. Best to contact Polk's CS department at: 1-800-377-7655 select option 1 and they'll help. Have your unit's serial number and date and place of purchase handy when you call.
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • Hello,
    Welcome to Polk's forum. In all likelihood the bass amplifier needs to be replaced or repaired. Best to contact Polk's CS department at: 1-800-377-7655 select option 1 and they'll help. Have your unit's serial number and date and place of purchase handy when you call.
    Regards, Ken

    Hi Kenneth - Unfortunately i am currently in India and Polk cannot ship a replacement to India. So support from Polk seems like a no go. I am technically sound so probably I can troubleshoot. The Relay switch no longer makes that click sound when it turns on so I think most probably its a power related issue.

    Any items I should check first?

    Thanks any help much appreciated.
  • KennethSwaugerKennethSwauger Moderator Posts: 6,837
    Hello,
    Let me try and get the amplifier's schematic and I'll send it to you.
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • Hello,
    Let me try and get the amplifier's schematic and I'll send it to you.
    Regards, Ken

    Many Thanks Kenneth, Kim did get in touch with me. Appreciate the brilliant support and responsiveness I would not expect any less from a brilliant brand Polk.

    Cheers!
  • longindolongindo Posts: 1
    hi kenneth
    i have exactly the same problem as above and i'm in Malawi where polk can't ship a replacement. would appreciate the tech support.
  • KennethSwaugerKennethSwauger Moderator Posts: 6,837
    Hello,
    Welcome to Polk's forum. I'll send your email address to Kim at Polk and I'm sure he can help.
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • Hello I have the 505 and noticed when I came home hearing noise coming from sub as if it is blown I checked woofer doesn't seem to be blown can I purchase a replacement woofer
  • KennethSwaugerKennethSwauger Moderator Posts: 6,837
    Hello,
    Welcome to Polk's forum. Contact Polk's CS department at: 1-800-377-7655 select option 1 and they'll help.
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • First time calling for service took care of my issue gave order number shipping out replace right away that's good service
  • KennethSwaugerKennethSwauger Moderator Posts: 6,837
    I'm glad they were able to help so quickly.
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • How do I check on order for shipping status for replacement amp for 505 sub
  • KennethSwaugerKennethSwauger Moderator Posts: 6,837
    If you haven't received an email with the tracking number give them a call at 1-800-377-7655 select option 1. Tomorrow morning.
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • I have the same model, a PSW505, last week it began losing audio, I ran it through several sources, I was only able to get faint audio with the speaker in. Fuse is ok, and connections seems ok when I took the plate off. Couldn't get my fingers all the way through the baffling to feel the connection to the speaker, but I gave it a gentle tug and it seems secure. The only think out of sorts on the board looks like some of reddish-molasses colored screw adhesive has tracked a little on the board (doesn't seem like it would have broken anything) The consensus seems to be my board is shot. Is it worth trying to troubleshoot more as a novice or should I just replace the board?
    ps previous to this, no buzzing or distortion... it just stopped.
  • KennethSwaugerKennethSwauger Moderator Posts: 6,837
    Hello,
    Welcome to Polk's forum. The best thing to do is contact Polk's CS department at: 1-800-377-7655 select option 1, with the long weekend they won't be back next Tuesday, I imagine. They will ask about the date and place of purchase.
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • joeelectronicjoeelectronic Posts: 1
    edited February 2018
    I encountered the same problem with "PSW505 light on rear not switching from red to green". It also makes a low frequency noise while in standby mode. It is out of warranty, anyone knows what to look for on the amplifier board? Thanks.
  • KennethSwaugerKennethSwauger Moderator Posts: 6,837
    Unless it's a burned resistor or leaky capacitor there's not much to actually look for on a circuit board. Most likely a component has failed but still looks okay from the outside. Polk can offer very reasonable repairs, certainly worth contacting them at 1-800-377-7655 select option 1.
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • surgesurge Posts: 1
    I just started to have the same problem. The light in the rear when switched on turns yellow now instead of green and makes some crakle sounds
  • KennethSwaugerKennethSwauger Moderator Posts: 6,837
    Hello,
    The place to begin is with Polk at: 1-800-377-7655 select option 1 and have serial number and date of purchase handy when calling.
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • Today my PSW505 went on the fritz as well. Initially, it was sending out low muddy notes not in sync with the rest of the audio. I noticed the light was red on the back of the unit. I actually have an extra Paradigm sub I hooked up to the LFE using the same RCA cable from the wall and it worked fine. The Polk sub will start red, flash to green, stay green and work for a while, then flash back and forth quickly while losing signal, then go back to red and lose all signal. Pretty sure it’s out of warranty, but also relatively confident I could fix it if anyone had an idea of where the problem lies?
  • Thank you this forum ,for this post. Todat my PSW505, gone bad while watching Missions Impossible Fallout. Flickering and cracking sound. Now watching without sub.

    Was not expecting this issues with Polk when first purchased.

    How I can get this resolved?
    Thanks

  • My PSW505 started doing the same. Seems to be stuck in standby. The red LED light stays on no matter what I do. I would be much appreciated if I could get this problem solved. Thanks...
  • KennethSwaugerKennethSwauger Moderator Posts: 6,837
    Hello,
    You'll want to contact Polk CS at: 1-800-377-7655 select option 1 and have the sub's serial number available when you call.
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!