Polk Magnifi Sound Bar suddenly stopped working

New polk magnifi soundbar won't respond to anything. Hit mute button this morning and all lights went out on front. Green light still on in back, woofer also lit up and green. Pressed all inputs, power on and off, etc. several times and no response from soundbar. Any ideas??!!

Comments

  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Hello,
    Welcome to Polk's forum, sorry you're having a problem. I believe the only thing you can try is to after switching off the AC power selectors on the soundbar and the subwoofer, then unplug the power supplies for both. Wait a few minutes then re-plug the power supplies and switch the AC selectors on. Hopefully this will get everything working again.
    If not, telephone Polk's CS department at: 1-800-377-7655 select option 1, they should be there this weekend.
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • Yes, so taking it off the wall and pulling the cords out for a minute and reconnecting worked.... The universal fix it for electronics. Thanks! Maybe this will help someone with the same problem.
  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    That's great, I'm glad it's working.
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • GeneWGeneW Posts: 1
    Same problem with mine...hit mute to take a 10 minute phone call then sound bar would not resume. Will attempt this fix
  • My new Polk signa S1 won't change between modes. Brand new out of the box. The only buttons that work are volume and it seems to be stuck on optic cable mode. Any ideas?
  • Hi, I've bought a Polk Audio Magnifi one 250 W six month ago and the subwoofer's started making noise and turning on and off sometimes without any reason why. I had plugged off and resync, it hasn't worked though
  • Why does the system work sometimes. It not other?
  • slope31slope31 Posts: 1
    For some reason my sound bar muted on certain channels the led light to the left turns green and then it mutes, I can change the channel nd the change it back and it unmutes
  • myerspatmyerspat Posts: 1
    Polk DSB1 sound comes in and out on blue tooth. Suggestions on how to fix?
  • smgomessmgomes Posts: 1
    hi, I'm from Brazil. I've bought a Polk Audio Magnifi one month ago, after first use the soundbar won't respond to anything. I had plugged off and resync, it hasn't worked though. The problem is that the product warranty is not global and I am outside the US. What if I try to connect on the internet? Any suggestion. Tks a lot. Sergio from Brazil.
  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Hello,
    I would recommend sending an email to: [email protected] explaining your situation.
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • WoomomWoomom Posts: 2
    NO SOUND!!
  • cfrizzcfrizz Posts: 13,249
    Woomom, see the above post from Ken Swauger.
    Marantz AV-7705 PrePro, Classé 5 ch. 200wpc Amp, Oppo 103 BluRay, Rotel RCD-1072 CDP, Sony Bravia KDL-40R510C TV, Polk S60 Main Speakers, Boston VR-920 Center Channel, SVS NSD-12 SB12 Subwoofer, Polk DSW 400 Subwoofer, Polk FXi-3 Surround Speakers
  • jassyjassy Posts: 2
    edited December 2018
    My brand new Polk soundbar with Alexa is not connecting to the internet. Any idea on how to reslove this? I restarted the soundbar and app and no luck. I'm outside of the US so not sure if it's location based. However I have other original echo devices and they work fine connecting to the internet so it's this crappy product.
  • jassyjassy Posts: 2
    Okay I solved the problem myself with the soundbar not connecting to the internet after not getting any response from Polk via their FB page.
    Pressing the microphone and the setup button on the soundbar simultaneously for five seconds initiates a green and blue lighted ring on the alexa.
    After this is done ask Alexa if she's connected to the internet and once she responds problem is solved.
  • We purchased the Polk DSB1 Sound Bar and subwoofer through Dish Network and the Dish tech installed it. The sound will automatically go really low for no reason and will change volume when changing channels. Any suggestions?
  • I have a 6 month old Magnify One sound bar with wireless sub. Worked fine until a few days ago when it stopped producing bass. Repeatedly I've gone through the reconnection process to get the sub and sound bar paired with same results - nothing but confusing. After I initiate the pairing process, the sound bar's green light blinks quickly, then I plug the power into the sub, and wait for it to pair. The sub's green light starts to blink and after about 20 seconds the sound bar stops blinking while the sub keeps blinking. After waiting about 10-15 seconds the sound bar starts blinking again and after about 20 seconds the sound bar and the sub's green lights stay lit and stop blinking, indicating they should be connected. Nothing from the sub! And nothing changed between the time it worked and when it didn't. I don't know if the issue is with the sub or the sound bar so if any of you have had the same problem and have the solution please pass it on.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!