M7 Failure

winshawwinshaw Posts: 1
edited May 2002 in Troubleshooting
Hello audiophiles,

One of my wife's 1990 vintage M7 floor speakers (that I have happily counted as marital property since 1998) has stopped working properly. It still produces sound, but is very muted -- it's barely audible when the other speaker is LOUD with the same input. I've already eliminated the amplifier and cables as potential causes. What should I do now?!?

--Win

p.s., I'm new to this forum and I don't see the 'lower right' button to alert the moderator of my issue -- any tips?
Post edited by winshaw on

Comments

  • nascarmannnascarmann Posts: 1,464
    edited May 2002
    Could be a number of things. Most likely the driver has gone bad. Take the grill off and just lightly push in on the driver and see if it has movement. If it does, put power to the speaker and touch the driver and see if it is moving. Try this and post a reply.
    Oh, the bottle has been to me, my closes friend, my worse enemy!
  • mantismantis Posts: 15,239
    edited May 2002
    If your up to the testing of the speaker,take it in to your local hi fi shop that does repairs.Better to take it to a dealer that carries that brand of speakers.
    Dan
    My personal quest is to save to world of bad audio, one thread at a time.
  • RuSsMaNRuSsMaN Posts: 17,995
    edited May 2002
    If you feel comfortable, take out the drivers, check for loose wires/burnt caps. You can test each driver individualy, with a low -power signal, direct to the driver, or a small AA battery (to test for active cone movement)

    Cheers,
    Russ
    Check your lips at the door woman. Shake your hips like battleships. Yeah, all the white girls trip when I sing at Sunday service.
  • nascarmannnascarmann Posts: 1,464
    edited May 2002
    Better to take it to a dealer that carries that brand of speakers

    Well they are Polk's, and they have 1 mid/bass driver. Bought in 1990 they should be the 7C's with a MW6502 driver and a SL2000 tweeter. Russman is right on testing, but I was just trying to get him started. Russman, you and I had a debate on the AA and 9 volt before about testing drivers I think?? Anyway, winshaw see if the driver is "not moving" when you lightly push in on it, or if it is moving when power is put to it and you can move to the next steps!
    Oh, the bottle has been to me, my closes friend, my worse enemy!
  • mantismantis Posts: 15,239
    edited May 2002
    There's nothing wrong with testing a speaker with a battery 9 volt or 1.5 volt, all that will happen is when wired in phase the driver moves out and pops.Out of phase does the opposite.
    Dan
    My personal quest is to save to world of bad audio, one thread at a time.
  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    edited May 2002
    Hello Win,
    Welcome to the Forum. Some things to check:
    1). it is possible there is a tweeter protection fuse, on the rear of the speaker cabinet where the speaker wires are connected. If the tweeter (high frequency component at the top of the speaker) is not working it could be the 1 Ampere normal blow fuse needs to be replaced.
    2). if you don't find a fuse, the tweeter itself could need replacing. The best way to check this out is to remove it from the cabinet (take out the four Phillips screws found at the four corners of the tweeter's faceplate) and disconnect the two wires on the back of the tweeter.
    3). at a very low volume play the tweeter directly from your audio receiver, connecting the receiver's speaker wire directly to the tweeters terminals. Keep the receiver's volume at around 8:00 o'clock (if you think of the volume control as the face of a clock) the tweeter should produce clear, undistorted sound.
    4). repeat the same thing with the 6.5" driver in the middle of the speaker, remove it from the cabinet, disconnect the two wires and try playing it with your receiver.
    5). when you check everything out note down the necessary part numbers found on the rear of each component and telephone us at 1-800-377-7655 and place an order for the parts, mentioning that you are a Club Polk member.
    Regards, Ken Swauger
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • PolkFreakPolkFreak Posts: 91
    edited May 2002
    I would just like for everyone to note that if this is a Polk speaker from 1990 it should be a Monitor 7 series 2. This has a SL2500 tweeter and a MW6502 driver. The Monitor 7C came out in about 1984-85. If the speaker were from the late 70's early 80's it should have a fuse on the crossover. In this case since the speaker is from 1990 we shouldn't have to consider a fuse as a possible problem.
  • nascarmannnascarmann Posts: 1,464
    edited May 2002
    Polk speaker from 1990 it should be a Monitor 7 series 2

    Yes it could be? There were plenty of the 10B's and 7C's on the shelf in 1990. I bought a new pair of 10B's in 1990!!
    Oh, the bottle has been to me, my closes friend, my worse enemy!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!