Help with RTA-11t problem

warlocks1warlocks1 Posts: 1,187
edited October 2002 in Troubleshooting
I blew one of the drivers a couple of months ago. I received a replacement from Polk. It then went back in the closet. I got them out today and something just isn't quite right. The replacement driver (the one below the tweeter) works but it only seems to be putting out bass. On the top driver and both on the other speaker there is definitely midrange and some vocals. I noticed that the replacement driver seems to be pumping out a lot more bass than the others. Could something be wrong with the crossover? I am thinking that is how I blew the other driver. I checked all the connections inside the speaker and everything seems OK. Any input would be appreciated. Thanks, Jeff
Post edited by warlocks1 on

Comments

  • hoosier21hoosier21 Posts: 4,394
    edited October 2002
    have you tried moving this driver to another position where you know midrange is coming from with another driver? it is possible you got a bad replacement.
    Dodd - Battery Preamp
    Monarchy Audio SE100 Delux - mono power amps
    Sony DVP-NS999ES - SACD player
    ADS 1230 - Polk SDA 2B
    DIY Stereo Subwoofer towers w/(4) 12 drivers each
    Crown K1 - Subwoofer amp
    Outlaw ICBM - crossover
    Beringher BFD - sub eq

    Where is the remote? Where is the $%#$% remote!

    "I've always been mad, I know I've been mad, like the most of us have...very hard to explain why you're mad, even if you're not mad..."
  • warlocks1warlocks1 Posts: 1,187
    edited October 2002
    I am sorry, I forgot to ad that part. Yes, I have switched drivers. Is is definitely not the driver.
  • HBombTooHBombToo Posts: 5,335
    edited October 2002
    Have you noticed any physical damage to the crossover like burn marks on the capacitor? If your only getting bass this could suggest that the highpass circuit on the crossover is torched.

    Just a thought.
    ***WAREMTAE***
  • hoosier21hoosier21 Posts: 4,394
    edited October 2002
    I would remove the crossover and return it to Polk for repair.
    Dodd - Battery Preamp
    Monarchy Audio SE100 Delux - mono power amps
    Sony DVP-NS999ES - SACD player
    ADS 1230 - Polk SDA 2B
    DIY Stereo Subwoofer towers w/(4) 12 drivers each
    Crown K1 - Subwoofer amp
    Outlaw ICBM - crossover
    Beringher BFD - sub eq

    Where is the remote? Where is the $%#$% remote!

    "I've always been mad, I know I've been mad, like the most of us have...very hard to explain why you're mad, even if you're not mad..."
  • warlocks1warlocks1 Posts: 1,187
    edited October 2002
    Well, I kinda of figured it out. I switched the top driver and the problem went away. Somehow, the top driver made the bottom driver not function properly, even though the top driver worked fine. I guess I need to order another 6510 driver. Anyone have one?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!