Subwoofer and surround speakers do not connect

Hello - I'm following directions on syncing my Magnifi Max with the sub. I traveled for couple of months and turned it off. I turned it on and it didn’t connect with soundbar.

I know I should activate syncing on the soundbar AND the sub, per the manual. But after several tries nothing works. I tried plugging/unplugging both multiple times. Also tried activating sync on the sub, and the soundbar, before and after each other.

What to do?

Answers

  • DendritDendrit Posts: 3
    I have the same problem with My magniFi Max sr and it seems to happen after update. The support has no idea what to do with it. And the problem is that i bought the bar in US and live not in US. So i Have dead sub and surround speakers for a few months now
  • joesephKjoesephK Posts: 19
    I had this issue but customer service walked me through fixing and this process worked for me:

    First sync just the subwoofer:
    1. Power on the sound bar if it’s not already on
    2. Press & hold the sync button on the sound bar until you hear the beep
    3. Press & hold the sync button on the subwoofer until you hear the beep
    4. Press & release the Sync button on the sound bar to exit and Save

    This will sync just the sub to the bar.

    Wait 1-2 minutes and see if the subwoofer starts to update which will be indicated by a pulsing white light on the sound bar. If lights on front of sound bar does not start to pulse white within a 1-2 minutes, then it is already up to date.


    Next, sync everything:
    1. Power on the sound bar if it’s not already on
    2. Press & hold the sync button on the sound bar until you hear the beep
    3. Press & hold the sync button on the subwoofer until you hear the beep
    4. Press & hold the sync button on one of the surround speakers until the light on the back of that surround speaker is solid green
    5. Press & hold the sync button on the other surround speaker until you hear the beep

    This will sync the sub and surrounds.

    All lights should be solid green on the back of the sound bar, sub, and surround speakers. If the surrounds need to be updated, you will see white pulsing LEDs begin to display on the front of the sound bar within a few minutes.
  • DendritDendrit Posts: 3
    When syncing the sub there is just no beep. It only flashes faster for period of time and thats all.
    Polk support is keeping silence for nearly a month. Seems its the first and the last one polk in my house
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!