Subwoofer stopped working

I have a 6 month old psw10 that stopped working - it just hums loudly, no other sound comes out of it. I can't seem to get through to Customer Service via telephone. What should I do next?

Comments

  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    edited August 2018
    Hello,
    I'll ask a friend at Polk to send you an email.
    Post edited by KennethSwauger on
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • mbauermbauer Posts: 2
    Thank you- much appreciated!
  • I have a subwoofer and the green light on back don’t turn on, what’s wrong?
  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Hello,
    Assuming you are referring to a PSW10 subwoofer that usually means there's either a blown AC fuse or a broken bass amplifier. If you've experienced a recent surge in your house electricity that could account for the fuse problem. If not, then it's probably more serious and Polk's CS can help at 1-800-377-7655 select option 1 and have the serial number available.
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • I have a pair of dsw pro 660s that are both cooked too. Who in CS did you talk to?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!