Magnifi Mini occasionally does not work. Forced to unplug / plug in power cable.

TonfunTonfun Posts: 5
edited December 2017 in Troubleshooting
I woke up this morning to see the amber power light on. My tv was off. I currently have optical and ARC connections to the bar with ARC chosen as the primary source. I chose it days ago using the remote. I turned on my tv. No sound. Light was still on. This has happened before and each time I'm forced to unplug the power cable and reinsert it to get the unit to function. When the bar is frozen like this no buttons work on anything not even the power button on the bar. What could be the issue? I've thought about using optical only to see if the bar freezes again. Maybe the HDMI ARC is faulty. The tv is an old Sony Bravia. The connection on the tv does say ARC.

I previously owned a bose solo 5 with no problems whatsoever but I wanted a compact bar with a subwoofer and believed polk to be among the best audio companies.

I've had my mini about a week. I have a month to take it back for whatever reason and that's something I've considered doing given my experience with the sound bar and customer service. Calling them resulted in almost two hours of being transferred to someone else. Nobody was able to deal with a firmware update apparently and at the time I couldn't connect the bar to my wi-fi for whatever reason. The google app didn't find it. The bar also froze for the first time that day. I got tired of the runaround. I hung up. I sent an email to customer service and never got a reply.

I finally connected the unit to my wi-fi network through google home. The app shows the firmware version to be 20. I guess that is the latest version.


  • TonfunTonfun Posts: 5
    edited December 2017
    I woke up again this morning to the same scenario and this time I left it on optical the night before not ARC. The amber light was lit as if it was on. The tv was off. I turned on the tv thinking I would hear sound. A message appeared on the tv stating "testing external speakers" which is normal. Then another appeared stating "using tv speakers" so the bar wasn't working. No sound. None of the buttons on the bar worked. The remote didn't work. I had to unplug the power cord and put it back in to force the bar to function properly.

    I did receive an email from support on the 15th. I sent my initial email on the 8th.
    Post edited by Tonfun on
  • Yesterday I woke up and the bar was fine. No amber light. Today I wake up and its there and no button worked. I had to do the power cord routine again to force it to work. I'm done. Its going back to Best Buy tomorrow. Customer service seems incompetent and this product does not perform as it should. Unplugging the cord is a temporary fix not a solution.
  • KennethSwaugerKennethSwauger Moderator Posts: 7,064
    If you can wait a short while, let me have someone from Polk contact you via email?
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • I have been contacted. I sent my initial email on the 8th and received a reply on the 15th. I immediately sent an answer. No reply yet since the 15th.
  • KennethSwaugerKennethSwauger Moderator Posts: 7,064
    I've asked a friend at Polk to contact you, he will be able to help.
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • Ok. I'll watch my email.
  • I am having this problem too. How do we fix this?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!