Lip sync issues with MagniFi Mini

I know this isn't really a soundbar issue but I'm wondering based on experience what TV's have the least amount of lip sync issues with this soundbar? I have a 50 inch Samsung MU6300 that is pretty bad. It's OK with streaming but running the cable box through the TV is pretty bad with Dolby Digital. Luckily this soundbar has both HDMI and Optical. So I can run sound direct from cable box to Mini and that works. Every now and then it's not perfect which makes no sense. The problem is I always have to switch back and forth. I would prefer just to use the HDMI ARC for everything. I know this is a Dolby Digital Processing issue on the TV because PCM works fine. Samsung does not really seem interested in fixing the issue. Looks like this might be a common issue with TV's and Soundbars and its a crap shoot on what TV and Soundbars may match better. So I'm hoping Polk knows what TV's work best with their soundbar for this issue.


  • heiney9heiney9 Posts: 23,921
    I have the same issue with my Vizio when I run HDMI ARC. I simply turn the soundbar off for 15-20 seconds and back on and that cures it. It doesn't happen too often so I just deal with it. Doesn't seem to have the issue when running optical out of the TV, but that's not convenient for me.

    "Appreciation of audio is a completely subjective human experience. Measurements can provide a measure of insight, but are no substitute for human judgment. Why are we looking to reduce a subjective experience to objective criteria anyway? The subtleties of music and audio reproduction are for those who appreciate it. Differentiation by numbers is for those who do not".--Nelson Pass

    Pass Aleph 30 | EE Avant Pre | EE Mini Max Plus DAC | MIT Shotgun S3 | MIT Z P/C's | updated SDA 1C| SQ Box Touch/Welbourne Labs P/S- Tubes add soul!
  • mhardy6647mhardy6647 Posts: 19,926
    There's a Milli Vanilli joke in here somewhere -- but I am, of course, too couth to stoop to such obviousness.


    Actually, this whole subject is a pet peeve of mine -- whenever I go into BJs to buy paper towels or whatever, that wall of cheap TVs sounds like a 1950s pop song echo chamber with the offset audio from set to set :/

    Sorry to go all Andy Rooney on y'all :blush:
  • NickJNickJ Posts: 2
    About the only way to really solve lip-sync error is to use a dedicated digital audio delay as made by Alchemy2, Felston and Primare. etc. (there may be others). I use a Felston DD740 but I think the others probably work as well since they all allow adjustment in 1 ms steps while watching without disturbing the image. Incidentally Samsung has an audio delay in their S/PDIF audio menu but it adjusts in huge 10 ms steps. But that's better than "no" adjustment as in Sony and Panasonic sets and better than Vizio's 20 ms steps. You really need 1 ms steps to ever feel it is perfect. The Felston even offers 1/3 ms but I never use that fine an adjustment.

    Adding one of these devices in the optical output from the TV and setting the TV to zero delay is the easiest connection but if you have a Sony or Panasonic it would be better to run digital audio from each source to the audio delay to bypass the audio delay those TV's add. Otherwise you can't correct cases where audio arrives already delayed. Of course if audio arrives delayed more than the TV's video delay you can't correct it.

    That connection (direct from each source bypassing the TV) also may be best if surround sound is important to you since most Samsung's do not support Dolby passt-through (all that I have seen in fact) which means you will only get surround sound from the TV's internal tuner or streaming service and not from any HDMI input.
  • Revisiting this since I've had more time to watch. I DON"T need a delay in the audio and that's the problem. It's exact opposite. The audio is delayed too much when watching TV. The delay adjustment NickJ mentioned works fine when streaming but again...that's not the problem. There have been some new developments though. This has to be some issue between the decoding from the Cox Contour box and live TV. As I mentioned connecting directly using the Optical cable does the best job. However sometimes even that starts to get off. Especially on some of the "Cable" channels like HGTV, FOOD Network, etc. Not so much on the major channels like NBC, ABC etc. Also DVR'd shows always seem to be in sync. The thing that bothers me is, that if I shut the Magnifi Mini box off and back on, the lips sync back up again. It's like there is some decoding issue. Shutting of the soundbar fixes it. Unfortunately the only option I have on the Contour box is to send the signal out Dolby Digital or PCM. I can't just send it out RAW.
  • Just noticed heiney9 comment about turning the box off and back on cures his issue momentarily as well. hmmmm.
  • rhody11rhody11 Posts: 2
    Having the exact same issues with mine on Verizon. Main channels and DVR work fine, but some other channels like HGTV, Paramount, etc have delays. Is there any fix???
  • I know this is an old thread but this issue continues to be a problem, and it's almost getting worse. The longer the soundbar is on, the worse the problem seems to become. Maybe a coincidence. There is definitely an issue in the soundbar itself between the cable box and the soundbar syncing. I turn the soundbar off and back on as mentioned above and the problem is solved. When I watch a DVR's show I sometimes have to turn it off and back on at the beginning of every show. It's like some sync is not happening. This started as more of an issue from the TV but now that I have the cable box connected directly to the soundbar it's a problem there as well. There has to be a reason, just don't know what it could be. I"m about ready to go back to a receiver.
  • KennethSwaugerKennethSwauger Moderator Posts: 6,765
    It's probably a good idea to check with Polk at: 1-800-377-7655 select option 1, hopefully they can make a suggestion.
    "And the house you live in will never fall down
    If you pity the stranger who stands at your gate" G.Lightfoot
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!