Signa S2-no sound

Got an S2 to use with a new LG OLED TV. It worked for two days (connected via ARC) then stopped. Can’t get any sound out of it. Sound works on TV’s internal speakers.

Any troubleshooting ideas?

Thanks.

Answers

  • KennethSwaugerKennethSwauger Moderator Posts: 7,691
    Probably a good way of testing the soundbar would be to use another source as a test. Maybe a portable CD player connected using the 3.5mm input on the bar. Or if you have a source device that uses a digital Toslink cable. That way you can see of the problem is the soundbar or not.
    "They say you shouldn't say nothin' about the dead unless it's good. He's dead. Good!", Jackie, "Moms" Mabley
  • AtoZ0to9AtoZ0to9 Posts: 2
    edited July 2020
    Try toggling the ARC in the LG's settings OFF and ON, I have to do it with my Samsung all the time.
  • Signa S2 worked great on HDMI ARC for two days, then quit. Works fine on Bluetooth. Troubleshooter on Samsung TV said bad HDMI cable. Replaced with new HDMI cable, nothing. Turning TV off and back on gives me speaker option of Receiver (HDMI Arc)-my Signa S2-but when I select it, it disappears and defaults to TV speakers.
    Thought I'd try a third new HDMI cable next.
    TV is new Samsung UN58RU7100
  • New HDMI cable no help.
    Can no one reply?
  • Had an older Samsung tv and it was fine with my Polk soundbar HDMI connection, got a new Samsung TV and it worked for a couple days, then disappeared. It connects via bluetooth but not HDMI, it's as if the Samsung TV can no longer detect that it has an audio device attached. Did you ever resolve your issue?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!