Dead PSW10?

Hi Everyone.

I just got a PSW10 for a simple den setup with a Yamaha sound bar that I had. Connection wise just taking Sub Out of the sound bar to the PSW 10 via a standard subwoofer cable (RCA > RCA) Hooked everything up, and powered on PSW10. When I did I got some really strange hum coming from the subwoofer - not that kind you get when you connect a cable with a sub already on but real low frequency stuff and then some horrible scratching sounds than nothing.

Thinking I just had a loose connection, I reseated the cable but when reseating I didn't get a buzz or hum as you typically would with the unit on.

As proceeded to test I was getting NO response out of the PSW10. Indeed turning the volume all the way up and adjusting the crossover did nothing. I of course adjusted controls on the SoundBar to no effect.

Frustrated I took the PSW10 into my home theater (denon x3000 and polk Pro 660) and disconnected my main subwoofer at the subwoofer and connected my the PSW10. Popped in a Blu-Ray and obvious sections with LFE did nothing on this little guy! No messing with the volume or Crossover did anything.

Plugging my bigger polk back in everything came to life as expected.

I'm getting power to the unit as shown by the green light on the back of the unit and I did take off the back panel to check the integrity of the fuse and it was fine.

So all an all not sure whats up.

I bought on Amazon but of course we tossed the box as it was a couple days from delivery until I actually got around to hooking things up (yeah rookie mistake). So I'm not sure if Polk directly can help me out or I need to go thru Amazon.

Any suggestion help - greatly appreciated.
Post edited by robbiecarman on

Comments

  • [Deleted User]
    [Deleted User] Posts: 7,659
    edited March 2014
    Hello,
    Welcome to Polk's forum. Try removing the grille cover and then take out all of the screws that go around the circumference of the woofer. Then use a putty knife to loosen up the woofer from the enclosure and pull the woofer out. Make sure there are two wires firmly attached to the woofer's terminals. If they seem connected correctly go ahead and remove them and place the woofer on a carpeted area of your floor and at a very low volume try playing the woofer directly powered by your receiver. It should make plenty of sound at a very low setting on the volume. If it is working then the problem is with the bass amplifier.
    Give Polk's CS guys a call on Monday at 1-800-377-7655 and have your unit's serial number and date of purchase handy when you call.
    They'll take care of you.
    Regards, Ken
  • Hinkler
    Hinkler Posts: 1
    Is sound quality a major issue for subwoofers , currently my amp does not have any pre out so i would have to connect it threw speaker level inputs, for now i know this adds a fair amount of distortion.
  • F1nut
    F1nut Posts: 46,296
    Hinkler wrote: »
    Is sound quality a major issue for subwoofers , currently my amp does not have any pre out so i would have to connect it threw speaker level inputs, for now i know this adds a fair amount of distortion.

    Not sure where you got that information, but it's false. In fact, the speaker level connection is superior to the line level.
    Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a t-u-r-d by the clean end."


    President of Club Polk

  • [Deleted User]
    [Deleted User] Posts: 7,659
    I can definitely smell spam.
  • rooftop59
    rooftop59 Posts: 7,296
    I can definitely smell spam.

    Nothing like the smell of fried spam and eggs first thing in the morning!!!
    Living Room 2.1: Usher BE-718 "tiny dancers"; Dual DIY Dayton audio RSS210HF-4 Subs with Dayton SPA-250 amps; Musical Fidelity A308; NAD M51 DAC; Sony UBP-x1000es; Squeezebox Touch with Bolder Power Supply
    Game Room HT: Denon AVR-X4200w; Sony UBP-x700; Definitive Technology Power Monitor 700 x3; Definitive Technology StudioMonitor 350; Definitive Technology ProMonitor 800; Sub - HSU VTF-2 MK5
    Master Bedroom
    Cambridge Azur 551r; Polk RT25i; ACI Titan Subwoofer