SDA2 - Speakers Not Working

Hello all...I have a set of vintage SDA-2 speakers. The left channel is working fantastic. The right, not so much. The configuration is tweeter, 2 mid-range and then the "bass" speaker. The left mid-range speaker is the only speaker that is working. The right mid-range is dead as well as the tweeter. I purchased replacement speakers from Midwest Speaker, hooked them up and have very limited sound coming from the right mid-range and nothing from the tweeter.

Yes, the interconnect cable is connected and I have the balance control in the middle. Do I need to replace the circuit board where all the speakers are connected?

Answers

  • michaeljhsda2michaeljhsda2 Posts: 1,924
    Does the interconnect cable fit tightly in the socket? A loose connection could be a possibility.
    SDA SRS 1.2TL's
    SDA 1C's w/Clarity Cap ESA; PA, Mills, RD0194-1's
    SDA 2B TL's w/RD0198-1's
    Yaqin MC-30L integrated tube amp
    Yaqin MS-20L integrated tube amp
  • All connections, including the interconnect cable, are tight. Double checked all the connections before coming on here...but always good to ask... B)
  • SchurkeySchurkey Posts: 1,895
    edited October 11
    SDA 2, with a single tweeter has to be SDA 2A or 2B. Third or fourth generation SDA.

    The left midrange, on the right channel cabinet, is the stereo driver. If the stereo driver works, and the tweeter doesn't, my FIRST suspect is a completely fried polyswitch. Beyond that, any wiring break including the potential for "open" capacitors could kill signal to the tweeter.

    Look at the schematic, trace the tweeter circuit back to where it splits from the midrange, and include the ground side of the circuit, too.

    The right midrange driver in the right channel cabinet is the SDA driver. It should also produce bass, based on the SDA inductor. If that driver is dead--no SDA, no bass--you need to trace the schematic and look for areas that would kill both the SDA and the bass signal. And again, don't forget about the ground side of the circuit.





    You have tried that amplifier/receiver with a different pair of speakers, to assure it's a speaker problem not a cooked amplifier channel, or a cooked source channel, or a failed speaker cable or interconnect...right?
  • Hey Schurkey, thanks for the response. It is the SDA-2A's...None of the wiring shows any breaks whatsoever....I have retraced the tweeter wire where it splits for the midrange and on the ground side...all wires clean with good solid connections...I am suspecting that the crossover is fried. I am going to try that next. Thanks!
  • Couple of things that I have tried to resolve this: I changed out both the tweeter and the left mid range speaker. That did not work. Figured it was the crossover, bought and changed that out, did not resolve the issue. I'm kinda at my wits end here. Could the culprit be the interconnect cable itself? I have checked the connections at both speakers, both ends fit snugly and firmly. I have checked all connections to all speakers, to the crossover and to and from the amp. Even tried using a receiver to see if that was the issue but still the same issue. I have checked the interconnect cable for any tears or splits but there are no marks, splits or cuts in the entire 20' length. Can the cable just be bad? Thanks in advance!
  • F1nutF1nut Posts: 42,900
    Have tested the cable and other connections with a meter?
    Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a t-u-r-d by the clean end."


    President of Club Polk

  • TennManTennMan Posts: 1,061
    The left mid-range speaker is the only speaker that is working. The right mid-range is dead as well as the tweeter.
    Disconnect all cables from the back of the speaker. Connect a 1.5 volt battery between the + and - terminals on the back of the speaker momentarily (observing proper polarity of the battery). When you do that both mid-woofers should move forward. Do they? If they don't move, your amp or the cables isn't the problem. The problem is internal to that speaker.
    SDA 2BTL · Sonicaps · Mills resistors · RDO-198s · New gaskets · H-nuts · Erse inductors · BH5 · Dynamat · Crossover upgrades by westmassguy
    Marantz 1504 AVR (front speaker pre-outs to Adcom 555)
    Adcom GFA-555 amp · Upgrades & speaker protection added by OldmanSRS
    Pioneer DV-610AV DVD/CD player
    SDA CRS+ · Hidden away in the closet
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!