Weird impedance 3.1 TL

So I got my drivers in the mail today and got around to installing them in one cabinet today and the impedance I’m getting at the input is 4.9 ohms. When I attach the interconnect cable is this going to come up a bit? Or do I to need go in and look for a problem? I assumed the impedance would be a bit closer to 8 ohms. BTW these are new to me and I’m in the process of installing the correct drivers.

Comments

  • F1nutF1nut Posts: 42,665
    You are measuring the resistance not the nominal impedance.
    Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a t-u-r-d by the clean end."


    President of Club Polk

  • AndohaspolkAndohaspolk Posts: 18
    Ok thanks! Will report back tomorrow when I assemble the other cab.
  • FestYboyFestYboy Posts: 3,698
    Yes, in almost all cases, DC resistance will be lower than advertised impedance.
  • AndohaspolkAndohaspolk Posts: 18
    Well I’m off to get screws to install the drivers in the other cab, also picking up an audio source amp 3 in mint condition for 75 bucks. I know it’s not the greatest of amps, but it’s local and it’ll get me up and running today!
  • Tony MTony M Posts: 8,299
    Well I’m off to get screws to install the drivers in the other cab, also picking up an audio source amp 3 in mint condition for 75 bucks. I know it’s not the greatest of amps, but it’s local and it’ll get me up and running today!

    I just read a review of that amp. You got a deal! ;) :p

    Enjoy. B)
    Most people just listen to music and watch movies. I EXPERIENCE them.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!