Advice with ms8 install

Jay23Jay23 Posts: 10
edited January 2014 in Car Audio & Electronics
I'm doing my first ever install...so far I have a sub and the ms8 installed.. Next step is to install new front speakers .. I have a used set of polk sr 6500s I also have brand new mm6501s and used db6510... I had bought the mm's then found the sr's and DBS .I plan to run active since I have the ms8 .. So heres my question.. I have no experience with installs or tuning.. Should I practice with the db's or mm's before i put in the sr's or just go for it with the sr's ... Any advice is appreciated and what I should look out for when tuning and doing the install
Post edited by Jay23 on

Comments

  • pentoncmpentoncm Posts: 379
    edited January 2014
    Just go ahead with the sr's. Where are the tweeters going?

    Cross the sub/mids around 50-60 hz 24db/octave.
    Cross tweeters 3-4khz, 12 or 24 db/octave .

    My guess is that the initial tune is going to be too bright and be a little thin. If so try cutting 2.5 to 5khz just a tad. Also play with increasing 1khz and 1.2 kHz just a little bit. Just initial suggestions but play around until you get things sounding right.
    Audison Bit Ten
    Kenwood X595
    Polk MM6501
    Polk MM1240
    Mtx 704x
    Alpine MRX50
  • Jay23Jay23 Posts: 10
    edited January 2014
    Stock sail panels for now... Thanks for the tips .. I tried to install today but couldn't get the speaker in..need to do some cutting
  • Jay23Jay23 Posts: 10
    edited January 2014
    Any advice on aiming the tweeter ..seems opposite side headrests are the place of choice
  • pentoncmpentoncm Posts: 379
    edited January 2014
    You could try angling the near tweeter to the center spot between both seats, then angle the far tweeter at the driver side glass right in between the a pillar and you. A little more on axis for the near May give you better width on the left and a little more off axis on the right may sound better and avoid the highs screaming at you.
    Audison Bit Ten
    Kenwood X595
    Polk MM6501
    Polk MM1240
    Mtx 704x
    Alpine MRX50
  • Jay23Jay23 Posts: 10
    edited January 2014
    Any recommendations for caps on my tweeter.. I just found out I should get one especially since I get pops currently with my speakers
  • pentoncmpentoncm Posts: 379
    edited January 2014
    Jay23 wrote: »
    Any recommendations for caps on my tweeter.. I just found out I should get one especially since I get pops currently with my speakers

    I'm curious why you need a cap on the tweeter. I don't have any and my tweets are fine off the bit ten. Pops sound like clipping to me .
    Audison Bit Ten
    Kenwood X595
    Polk MM6501
    Polk MM1240
    Mtx 704x
    Alpine MRX50
  • Jay23Jay23 Posts: 10
    edited January 2014
    http://www.diymobileaudio.com/forum/technical-advanced-car-audio-discussion/116946-tweeter-caps.html

    I just read about this. I get pop noises because my remote comes from my fuse box for all of my equipment ..and factory amps remote is from the headunit... Or so I believe is the cause of my pops due to my research.. The pops are when the car starts and shuts off not during music play..Also someone on here mentioned they blew an sr tweeter when they had it running active with an ms8. .. I am by no means an expert but this article plus talking to some other ppl who have used the ms8 scared the crap out of me.. Supposedly it just helps make sure things that shouldn't be heard through the tweeters don't get to them
  • Jay23Jay23 Posts: 10
    edited January 2014
    I don't want to blow my tweeters lol
  • pentoncmpentoncm Posts: 379
    edited January 2014
    Jay23 wrote: »
    I don't want to blow my tweeters lol

    In my system my hu turns on, followed by bit ten, then amps. So does your amp turn on before the ms8?
    Audison Bit Ten
    Kenwood X595
    Polk MM6501
    Polk MM1240
    Mtx 704x
    Alpine MRX50
  • Jay23Jay23 Posts: 10
    edited January 2014
    So headunit and factory amp are together... Then ms8 and aftermarket amp are together... Ms8 before aftermarket amp... And my ms8 has a delay and does not come on as quickly as my headunit... And now because of the cold it takes a couple more seconds to turn on .. So only my factory amp turns on before the ms8
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!