143!!!!!

MOMOcivic
MOMOcivic Posts: 20
edited May 2003 in Car Subwoofer Talk
Well I entered my first show today. I have a pair of MM124's ran with a Rockford 700s. The speakers are bridged to about 350 each and I hit 143db. Does anyone know if that's good or not? Also I am having a problem with my speakers slapping on certain notes and was wondering if anyone else was having that problem...otherwise I am pretty happy with my 143. Thanks Guys
1 pair MM124
2 pair MM6 6.5
1 Rockford 700s for the subs
1 Rockford 500x for the seperates
1 Rockford One Farad Cap
Sony Xav-7w head unit
All Monster wire, RCA's, fuse blocks and battery terminals.
Post edited by MOMOcivic on

Comments

  • PoweredByDodge
    PoweredByDodge Posts: 4,183
    edited May 2003
    700S ?? if u have two momo's off that then you're running that amp at 2 ohms... that's not really good for the amp and could lead to problems down the road.

    slapping? distortion. plain and simple. it cant be overpowering, as they'll do plenty mor ethan that... but i would say distortion / overdriving of the amp / etc etc.

    far as 143 -- if its on the dash with an accepted mic, that's actually very good for two momo's in sealed boxes. my congratulations go out to you on that one... especially with only like 350 per sub.... good job dude. :)
    "With your own attitude it is hard to survive here... But who gives a damn, we are here to change the world, and we dont need a password for that."
    - Anurag
  • MOMOcivic
    MOMOcivic Posts: 20
    edited May 2003
    it was an IASCA event so the mike was on the dash. ya everyone was really suprised at what i hit and so was i. Thanks for the props man.
    1 pair MM124
    2 pair MM6 6.5
    1 Rockford 700s for the subs
    1 Rockford 500x for the seperates
    1 Rockford One Farad Cap
    Sony Xav-7w head unit
    All Monster wire, RCA's, fuse blocks and battery terminals.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!