Please Help with replacement Driver.

warlocks1warlocks1 Posts: 1,187
edited April 2002 in Technical/Setup
I just received my MW6510 driver from Polk for my RTA-11t's. The old one would botom out at moderate levels. I installed the new driver and matched the white and black cables. Now I only get sound from the tweeter. I reinstalled my old driver and everything is great (except the bottoming out problem). What's the deal? Did I get a bad driver and would that cause the problem in the other driver's sound level? Should I try reversing the wires? Thanks, Jeff
Post edited by warlocks1 on

Comments

  • RuSsMaNRuSsMaN Posts: 17,995
    edited April 2002
    Even with polarity reversed, you will still get sound from a functional driver.

    Hook the raw driver up to the speaker wire from your amp (free air), AT A VERY LOW LEVEL, and you should hear something....if you don't, call cs and send it back.....

    Cheers,
    Russ
    Check your lips at the door woman. Shake your hips like battleships. Yeah, all the white girls trip when I sing at Sunday service.
  • warlocks1warlocks1 Posts: 1,187
    edited April 2002
    Wow, that was fast! Thanks Russ. I will give it a try.
  • warlocks1warlocks1 Posts: 1,187
    edited April 2002
    I just tried and I get no sound whatsoever. I will call them tomorrow. I know it won't be a hassle, that's why I love Polk Audio. Again, thanks for the help!
  • axemanaxeman Posts: 170
    edited April 2002
    Sounds like you just got a lemon.......................a real rarity for Polk, but rest assured they will make it right.

    That is why they are GREAT!!!!

    Peace,
    Joe
    An Unused Weapon Is A Useless Weapon!!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!