LMS 8

Options
FYI

I have been using LMS 7.?? (Logitech Music Server) to access local music and stream Tidal controlled using Squeezer on my cell phone.

Tidal stopped streaming during the last month or so. Something to do with no more Ickstream support.

I did some research and upgraded from LMS 7 to LMS 8. With LMS 8 I can stream Tidal again and Squeezer is much better. Now I can search for a band and see both the local music and streamed music together on the same screen with a button to search Tidal for more selections.

Works nice........
Mojo Audio Illuminati v3>>Quantum Byte w/LMS>>Rpi/PiCoreplayer>> Starlight 7 USB >> Mojo Audio Mystique v2 SE>>ModWright SWL 9.0 SE Signature>>Hafler DH-500 Amp+ (Musical Concepts Fully Modded)>>
SRS 2.3TL (Fully Modded)...Velodyne Optimum 8 subwoofer
1KVA Dreadnought

Marantz SA 8005
Pioneer PLX-1000 Turntable - Shure SC35C/N35X - V15III/VN35HE
Yamaha TX-540 Tuner...Sony BDP-S570
Sony PS4

Separate subpanel with four dedicated 20 amp circuits.
1. Amplification 2. Analog 3. Digital 4. Video

"All THAT IS LOST FROM THE SOURCE IS LOST FOREVER"

Comments

  • msg
    msg Posts: 9,446
    Options
    Interesting. I didn't know 8 was out.
    I disabled signatures.
  • machone
    machone Posts: 1,475
    Options
    It's a Beta version.
    I had to search for a link. I could not find it on their website. I think I found the link in a forum.
    Mojo Audio Illuminati v3>>Quantum Byte w/LMS>>Rpi/PiCoreplayer>> Starlight 7 USB >> Mojo Audio Mystique v2 SE>>ModWright SWL 9.0 SE Signature>>Hafler DH-500 Amp+ (Musical Concepts Fully Modded)>>
    SRS 2.3TL (Fully Modded)...Velodyne Optimum 8 subwoofer
    1KVA Dreadnought

    Marantz SA 8005
    Pioneer PLX-1000 Turntable - Shure SC35C/N35X - V15III/VN35HE
    Yamaha TX-540 Tuner...Sony BDP-S570
    Sony PS4

    Separate subpanel with four dedicated 20 amp circuits.
    1. Amplification 2. Analog 3. Digital 4. Video

    "All THAT IS LOST FROM THE SOURCE IS LOST FOREVER"
  • msg
    msg Posts: 9,446
    Options
    Which version are you running now? I just did an upgrade and some weird, weird stuff happened. Got it sorted, and pretty sure it was a compound issue of some host firewall stuff, but my Spotty stopped working, and that was a show stopper.

    This post was nearly 3yrs ago - who cares, I'm into necro; so what - but it's still relevant. and I'm of the mindset that knowledge is knowledge, and I've no problem posting to old threads.
    I disabled signatures.
  • Gardenstater
    Gardenstater Posts: 4,184
    Options
    I have been holding off on upgrading and now I'm afraid to. Host firewall stuff? Is Spotify working now?
    George / NJ

    Polk 7B main speakers, std. mods+ (1979, orig owner)
    Martin Logan Dynamo sub w/6ft 14awg Power Cord
    Crown D150 amp
    Logitech Squeezebox Touch Streamer w/EDO applet
    iFi nano iDSD DAC
    iPurifier3
    iDefender w/ iPower PS
    Custom Steve Wilson 1m UPOCC Interconnect
    iFi Mercury 0.5m OFHC continuous cast copper USB cable
    Custom Ribbon Speaker Cables, 5ft long, 4N Copper, 14awg, ultra low inductance
    Custom Vibration Isolation Speaker Stands and Sub Platform
  • msg
    msg Posts: 9,446
    edited May 2023
    Options
    Yes, it's working now. It wasn't really a big deal after I figured out what was probably happening. I'm mobile at the moment, but will post back with more info. You can always revert to a previous version of it doesn't work out. There are some LMS specific folders to take a copy of, just in case.
    I disabled signatures.
  • msg
    msg Posts: 9,446
    Options
    @Gardenstater
    "host firewall" was just a fancy way of saying Windows Firewall - sorry, work on the brain, ha.

    I'm running my LMS on an older computer build, and over the years it's picked up a bunch of automatic firewall rules that never went away when the original software was updated or removed. What ever it was that was going on, went away when I reset Windows Firewall to defaults and just let everything rebuild.

    I did create manual firewall rules for LMS's required ports, but I'm not sure you'd need to. It's easy anyway.

    You can update, but to be on the safe side, in addition to a regular system backup, I always take a manual copy of the following before doing so:

    Preferences & Favorites
    C:\ProgramData\Squeezebox\prefs (this folder contains your favorites - favorites.opml; in case you're interested, you can edit this file in a nice text editor like Notepad++ to make bulk updates to your Favorites. Recommend taking a working copy to edit, make a backup of the original, and then replace with your updated version if you do this. Handy from time to time.)

    Plugins
    C:\ProgramData\Squeezebox\Cache\InstalledPlugins\Plugins (<< double-check on this; I have a note in my notes to confirm this location)
    I back these up just in case something goes wrong.

    I never update directly through the browser without first acquiring a copy of the installer to save. This so that I always have an installer copy just in case all online files access for LMS ever goes away. Once you have that, you could install through the browser notification if you wanted to, presuming you already have the current version's installer saved.
    If you have automatic downloads enabled, the LMS updates are downloaded here:
    C:\ProgramData\Squeezebox\Cache\updates


    I'm not sure all these links are current anymore, but copying/pasting out of my notes
    Updates and Downloads
    https://downloads.slimdevices.com/
    https://wiki.slimdevices.com/index.php/Nightly_Builds.html
    https://github.com/Logitech/slimserver
    https://downloads.slimdevices.com/nightly/index.php?ver=8.3

    If you do not yet have an image-based system backup solution, I can recommend Veeam's Microsoft Agent for Windows. It's free, but you do have to sign up. Easy to set up for a techie like you B)
    Install, create your backup media as an .iso, schedule your full system backup to an external drive to run daily. It only backs up changes between whenever the full system backup is configured to run. Great little tool that you can use for single file recovery, or even full system, bare-metal recovery. Very generous of Veeam to be giving this away. Handy for those oopsie moments. Or if LMS totally hoses you add you just want a time machine

    Last note - the newest Spotty plugin requires that you run Spotify on a mobile device or computer first - specifically not the browser version - and then choose the LMS/SBT from the list of Spotify Connect devices. For me, this wasn't working because of the firewall BS. Once I cleared that up, it blew right through, and reauthorized, and I was back up and running in no time. Other than that, no issues. I've updated LMS and all the plugins to latest versions. Working fine.




    I disabled signatures.
  • recoveryone
    Options
    Still amazing how LMS/and many of the old slim devices are still working hard after Logictech killed it off almost a decade ago. I still have a working V3 (Classic), duet and several Touch's throughout my home. I just picked up a Eversolo DMP A6, it's nice, but I have to think this is what the next generation of a Touch would have been. I will be putting out my part 2 video on the A6 this weekend.
    Family Room HT 7.2/i]:Vizio Oled55h1 Pioneer Elite SC-LX502 Pioneer Elite BDP 85FD Eversolo DMP A6 Panamax M5300-EXSpeakers Fronts Fluance XF8L Center Polk Audio S35 Side Surrounds Optimus LS30's Rear Surrounds Optimus LS30's Subs SVS PB4000 x2 Living room 2ch: Crown Xli 1500 amp Teac EQ MKII FX Audio X6 Mk II DAC Squeezebox Touch Fluance Signature Tower Speakers Panamax M5100-EXOffice media room:Vizio M50Q6 50" Pioneer Elite VSX LX103 Squeezebox Touch Polkaudio R50 Towers Polkaudio CS 10 Panamax M4300 Monoprice 12" subMaster bedroom:Vizio M55Q7 Pioneer Elite VSX LX302 Pioneer Elite BDP 85FD Squeezebox Touch Polk audio RTi 6 fronts, Rears Dayton B652 Polk Audio CS10 center Monoprice 12" sub Panamax M5300-EX
  • machone
    machone Posts: 1,475
    Options
    msg wrote: »
    Which version are you running now? I just did an upgrade and some weird, weird stuff happened. Got it sorted, and pretty sure it was a compound issue of some host firewall stuff, but my Spotty stopped working, and that was a show stopper.

    This post was nearly 3yrs ago - who cares, I'm into necro; so what - but it's still relevant. and I'm of the mindset that knowledge is knowledge, and I've no problem posting to old threads.

    Just saw this. Still using the version of 8 that installed back in 2020 with no issues. Squeezer gets an upgrades for the better from time to time.
    Mojo Audio Illuminati v3>>Quantum Byte w/LMS>>Rpi/PiCoreplayer>> Starlight 7 USB >> Mojo Audio Mystique v2 SE>>ModWright SWL 9.0 SE Signature>>Hafler DH-500 Amp+ (Musical Concepts Fully Modded)>>
    SRS 2.3TL (Fully Modded)...Velodyne Optimum 8 subwoofer
    1KVA Dreadnought

    Marantz SA 8005
    Pioneer PLX-1000 Turntable - Shure SC35C/N35X - V15III/VN35HE
    Yamaha TX-540 Tuner...Sony BDP-S570
    Sony PS4

    Separate subpanel with four dedicated 20 amp circuits.
    1. Amplification 2. Analog 3. Digital 4. Video

    "All THAT IS LOST FROM THE SOURCE IS LOST FOREVER"