Jolida JD-100 repair

acmf74acmf74 Posts: 896
Polks,

My CDP as of recent has been cutting out/turning off while its playing. I checked the connections and they are all snug. I'm suspecting it needs repair after years of use. Can anyone recommend a shop for repair preferably in the NY area?

TIA

Comments

  • F1nutF1nut Posts: 44,510
    Have you replaced the tubes?
    Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a t-u-r-d by the clean end."


    President of Club Polk

  • acmf74acmf74 Posts: 896
    I have not. I do have the pair that came stock with the player with very low hours. I switched out to the Psvanes when it was relatively new. Would tubes on there way out cause this?
  • txcoastal1txcoastal1 Posts: 11,231
    Yes
    2-channel: Modwright KWI-200 Integrated, Dynaudio C1-II Signatures
    Desktop rig: LSi7, Polk 110sub, Dayens Ampino amp, W4S DAC/pre, Sonos, JRiver
    Gear on standby: Melody 101 tube pre, Unison Research Simply Italy Integrated
    Gone to new homes: (Matt Polk's)Threshold Stasis SA12e monoblocks, Pass XA30.5 amp, Usher MD2 speakers, Dynaudio C4 platinum speakers, Modwright LS100 (voltz), Simaudio 780D DAC

    erat interfectorem cesar et **** dictatorem dicere a
  • F1nutF1nut Posts: 44,510
    acmf74 wrote: »
    I have not. I do have the pair that came stock with the player with very low hours. I switched out to the Psvanes when it was relatively new. Would tubes on there way out cause this?

    Yeah, but let me ask is the sound dropping/cutting out or is the player losing power because rereading your OP you say, "turning off."
    Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a t-u-r-d by the clean end."


    President of Club Polk

  • acmf74acmf74 Posts: 896
    The unit would either go into a standby mode or completely turn off while playing (meaning the power light and LCD screen would power off). I swapped out to the stock tubes and it shutoff completely again this morning.
  • F1nutF1nut Posts: 44,510
    Ok, tubes aren't the problem. I recommend contacting Michael Allen at Jolida, https://www.jolida.com/
    Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a t-u-r-d by the clean end."


    President of Club Polk

  • acmf74acmf74 Posts: 896
  • F1nutF1nut Posts: 44,510
    I suspect a power supply issue, but I can't tell you exactly what.
    Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a t-u-r-d by the clean end."


    President of Club Polk

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!