A discussion about streaming DSD over your home network


I have been finding out some very interesting information about trying to be able to stream DSD (Direct Stream Digital) files over my home network on my Oppo UDP-205. I first started doing this when Oppo released a firmware update for the BDP-103. At the time I had a BDP-93 and couldn’t figure out whether or not it was worth it to upgrade to the newer 103. When I found out about the firmware update I practically ran out and bought a 103 and sold my 93! See at that time the only way that anyone could play a downloaded DSD file, which were becoming available right about that time. Was with some expensive outboard DAC’s. I began purchasing albums in DSD format from various sources including superhirez.com and nativedsd.com. hdtracks.com came on board with DSD files much later. I found out from stereophile magazine that you can not only play the files from a USB stick, but you can also stream them from your computer via the SMB (Server Messenger Block) Something that Apple stopped supporting years ago. So only Windows computers would do it. When using the SMB the computer sees it as essentially the same thing as playing the file from a USB stick (without of course going through the hassle of transferring the file to a USB stick and then plugging it into the Oppo. This after finding one with enough capacity to handle these files which are HUGE. About the same size as a short HD movie in some cases)
If you look at the pic above you can see the list of devices from which I am able to stream files to my Oppo. The tv is the one in the middle. The three at the top are all DLNA (Digital Living Network Alliance) from my computer and two network back up hard drives. DLNA doesn’t recognize DSD files, so ifI try to access them using that. Even if I go into the folder I created for the DSD files, the folder would show as empty. The three at the bottom are all SMB from my computer and one of the network back up hard drives. One of them has gone south on me, so I had to get another one. When it began acting up, first it disappeared from my computers list of network devices. Then the SMB capability disappeared from the Oppo’s menu. It took a while to figure out what was going on and I reached out to Microsoft about it thinking it was a problem with Windows. When that went nowhere I reached out to Western Digital. They sent me a series of links to Microsoft pages dealing with the issue and from there I discovered the latest versions of Windows 10 come with the SMB capability turned off by default and how to turn it on. This did not work and after trying each and everything that the good folks from Western Digital sent to me, they arranged a phone call with me and I had a level 2 representative look through my computer in an effort to see what the problem was. They initially thought there was something wrong with my computer, but after trying seventeen ways to Sunday to gain access to the back up hard drive with no success, they realized it was failing. So I bought another one on eBay and installed it and lo and behold the SMB capability came back again!!
Again this was after turning on the SMB capability in Windows (which after not working initially and then finding an older version of Windows 10 after looking everywhere. majorgeeks.com was a big help here) I realized the problem lies with the hard drive.

Now all I have to do is find a way to get all of my music 🎶 🎼 and movies 🎥 and pictures off of the old back up hard drive and onto the newer one or my computer.
Has anyone else tried streaming DSD?
If so how has it worked for you?
Did you know the Oppo BDP-103 and 105 as well as the UDP-203 and 205 were capable of this?
They will play DFF and DSF cabinet file DSD music files in stereo and multichannel form.


  • honestaquarianhonestaquarian Posts: 2,554
    Above is a multichannel DSF cabinet file DSD recording streaming to my Oppo from my backup hard drive (which is in another room) over my home network via the SMB.
  • honestaquarianhonestaquarian Posts: 2,554

    Just decided to click on one of the free music download like at Oppo’s website. This time I decided to try the 2l link and downloaded several samples of the same tracks to see if I could hear a difference. Some DXD (24bit/352.kHz) some MQA and some DSD in 2.8mhz, 5.6mhz and 11.2 mhz sampling rates. I wanted to see if I could hear a difference and also which ones the Oppo would play.
    It wouldn’t play the 11.2mhz samples (quad DSD)but it would play the 5.6mhz samples (double DSD) and the 2.8 mhz samples. I thought I heard a bit of a difference between the 2.8mhz and the 5.6mhz samples. This is just preliminary, but the 5.6mhz samples seemed to sound just a tad more..........well smooth and/or natural???
    More listening is needed
    Again the ONLY way to listen to these files is by either transferring them to a USB stick or to stream them via the SMB.
  • honestaquarianhonestaquarian Posts: 2,554
    Then there's the stereo MQA versus 2.8 mhz stereo DSD comparison which really doesn't yield much of a difference to my ears depending on the program material. On SOME music I can hear a slight difference, but on other material I cannot hear a difference.
  • afterburntafterburnt Posts: 6,033
    I do believe that my Oppo and my Yami AVR are able to play native DSD but I have not used them in ages for much of anything. I will try it and see, that is if I can figure it out. The jury is certainly out on this one because I have found that a lot of my "red book" stuff is superior to the "hi rez" equivalent. As I said somewhere else, I have not much patience for critical listening nor the time to really sit and listen these days. I just let stuff play.
  • afterburntafterburnt Posts: 6,033
    As a matter of fact, my streamer just got done with the lineup and now I have to find my phone lol.
  • erniejadeerniejade Posts: 5,152
    "I discovered the latest versions of Windows 10 come with the SMB capability turned off by default and how to turn it on. "

    This also messed with me when I got a newer version of 10. Ticked me off that's for sure!
    Den: Lumin D1,Wireworld Silver Eclipse, KEF LS50 Wireless, Velodyne SPL1200, Technics 1200, Denon DL160, Jolida D9,

    Living Room:,T+A PA 1530R, Tyler Highland H2, Aries Mini, High Fidelity Reveal RCA, Grant Fidelity Tube Dac 11, W4S recovery, Wireworld Platinum Starlight, PS Audio Direct Stream JR.

    Have but haven't used in a while: LH Labs VI Dac, Cayin SCD50T

  • honestaquarianhonestaquarian Posts: 2,554
    Well prior to all of that happening with the backup hard drive, after one of the Windows 10 updates I could no longer log into my computer via the SMB. Suddenly my name and password wouldn't work no matter what I did. I had no problems getting into the backup hard drive via the SMB. I contacted Oppo about it and they responded the unit doesn't support SMB 3.0. I asked if there was any kind of firmware update which could possibly solve this and they responded it was a mechanical issue and that was that.
    Here are a couple of the links that Western Digital sent to me to help with the issue.



    They will show you where to go and what to turn on in order to get the SMB working.
    Make sure you read the articles on why Microsoft decided to turn off the SMB.
    I haven't even tried to log into my computer via the SMB at this point. what I've done is to go into the second backup hard drive via the NFS in the middle of the list there in the pic with the IP address. I can stream all of my DSD from there.
  • honestaquarianhonestaquarian Posts: 2,554
    Does anyone have any idea how much it would cost to have my files retrieved from my old backup hard drive which is failing?
    I have a lot of music on there along with movies and pics and I really do not want to have to pay to download all of those DSD files again.
  • afterburntafterburnt Posts: 6,033
    Does anyone have any idea how much it would cost to have my files retrieved from my old backup hard drive which is failing?
    I have a lot of music on there along with movies and pics and I really do not want to have to pay to download all of those DSD files again.

    That's confusing. Is it in fact, a "back up? I have heard that it is expensive to recover a bad drive, they have to open it up in a clean room and try to salvage the platters so i can imagine it's pretty pricey. I guess it comes down to what is cheaper, recover or replace.
  • honestaquarianhonestaquarian Posts: 2,554
    @afterburnt It is in fact a back up. The main hard drive inside my computer works just fine. This one is on the other side of the room and is connected to my router (it's the Mybooklive that you see in the pics. The Mybooklive2 is the second one that I recently got, because this one has been slowly failing over the course of a year and I didn't initially realize that the problem lied with it)
    What does expensive mean?
    A couple hundred?
    A couple thousand?
  • afterburntafterburnt Posts: 6,033
    @honestaquarian Hundreds I would imagine. So your pc drive does not have your media files on it?
  • honestaquarianhonestaquarian Posts: 2,554
    I have had to reinstall Windows 10 several times over the years. Each time I do it I move all of the media to the backup hard drive.
    That plus the fact that whenever I wanted to stream DSD over the SMB, if I did it from my computer it would stutter and buffer and what not. Never had a problem streaming from the backup hard drive via the SMB.
    It has always been seamless.
    Then after a while I could not get into the computer via the SMB with the Oppo. I checked with Oppo and they said it doesn't support SMB3.0.
    So needless to say I had moved a lot of stuff over throughout the years.
  • afterburntafterburnt Posts: 6,033
    I am super paranoid so I have a NAS raid one backed up by another raid 1 plus a lot of my stuff on at least 3 more individual drives, a couple of which leave home with me every day. Seagate taught me a lesson a while back.

    So is your backup completely dead or just unreliable?
  • honestaquarianhonestaquarian Posts: 2,554
    It is on and can be seen by my peripherals, but when I try to go into it they see nothing in the folders now. This has been a slow and long time coming. Bit by bit it has become more and more difficult to access the files on it. I think that was part of the problem and it wasn't until I contacted Western Digital that we both realized the drive was the problem and not my computer or Windows.
    Initially I thought it was an issue with my computer or Windows. The guy who helped me at Western Digital initially thought the same.
    As of right now I can't even access any of the music, movies or pics on it, because the folders show as empty when I try to get into it with the Oppo, my smart TV or my Playstation 3 via DLNA. As you can see on the pic it doesn't even show up on the SMB anymore. What you're seeing is the other backup hard drive that I just got.
    If I knew it would cost me several hundred dollars or more to retrieve my files then I would say screw it and toss it.
    Back to HDtracks, Native DSD and Superhirez dot com it is!
  • honestaquarianhonestaquarian Posts: 2,554
    edited April 2019
    @afterburnt I downloaded it and ran the scan. It only found what was hooked up to the computer (that being the C drive and all of the USB peripherals) The backup hard drives are hooked up to the router.
    Thanks for the effort tho!
  • afterburntafterburnt Posts: 6,033
    @honestaquarian can you move it to your pc? I would get a new drive and try to coppy it, they are realatively cheap and useful even if I doesn't work.
  • honestaquarianhonestaquarian Posts: 2,554

    My tablet takes horrible pics, however as you can see it's fully enclosed. So the simple answer would be no.
  • monepolkmonepolk Posts: 1,059
    So you can't disconnect it from the router and connect it to your PC??
  • honestaquarianhonestaquarian Posts: 2,554
    edited April 2019
    It is connected via Ethernet and not USB and I tried doing that a couple of times (including when I was instructed to do it during the call with Western Digital)
    It doesn't work.
    The PC can't see it.
    The guy at Western Digital tried twelve ways to Sunday to get into it and he couldn't do it.
  • monepolkmonepolk Posts: 1,059
    Did you try a different ethernet cable? Just to eliminate that.
  • honestaquarianhonestaquarian Posts: 2,554
    Again this has been a v e r y s l o w process of failure which has been happening for more than a year. This is why I didn't think it was the hard drive that was the problem and neither did the tech at Western Digital until he could not get into the drive no mater what method he tired (and he tried many-some of which I wasn't even aware of)
  • monepolkmonepolk Posts: 1,059
    I had an backup hard drive fail on me. But it was because it fail why moving things around. After trying everything I could think of, I checked out YouTube on how to take it apart. I removed the hard drive and put it in an extra bay in my computer to see if it worked. I didn't, but since I took the case apart carefully I bought a bare HD and put it in the old case.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!