2.3TL Crossover Help

Hey all, I need help!

Thanks to gmcman, I have new (really big) capacitors for my 2.3TLs. With the help of a friend, I did the crossover upgrade today on the right channel only. When I put it back in, I had lost the SDA effect. The SDA speakers aren't playing at all.

I used Gimpod's boards (which are amazing!!!) and I'm using a beat up old RCA cable for the IC. It's bad, but it worked before.

Any ideas on what I did wrong? I'm stumped at what to even try. It's possible we wired something incorrectly, but we went through it with a meter and it looked ok.

I attached a couple pictures I took during the process. If you need to see something else, let me know and I'll take it out and do more pictures.

Thanks in advance!

n5o7owtia64i.jpg
qrpwzxgtonvc.jpg
2 Channel: Polk Audio SDA SRS 2.3tl with Clarity CMR caps and Gaia II speaker feet, Atoll IN300 integrated amp, SotM sMS-200 ultra streamer, SotM sPS-500 power supply, and infinite baffle subwoofer with two Fi Audio IB318 drivers.

HT: Polk Audio speakers: 2.3tl front, CSiA6 center, 500-LS ceiling, RT/FX, RTi8, Monitor 4 rears, and IB subwoofer, Yamaha CX-a5100 AV Preamplifier/Processor, Yamaha MX-a5000 11.1 channel amplifier, Sony XBR55-AE1 OLED TV.

Comments

  • F1nutF1nut Posts: 40,631
    The first thing you should check is your SDA cable.

    Did you put a jumper between I and K?
    Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a t-u-r-d by the clean end."


  • gmcmangmcman Posts: 1,268
    I've been working on mine as well, won't get them both finished tonight.

    I would double check your two larger board inductor leads.

    Can you post a pic of the underside?

    This is from my current board.

    y3wl1v1nzgmo.jpg
  • BC6BC6 Posts: 72
    The SDA cable is a piece of junk, but it worked before. We did put the jumper between I and K, but I'll double check to make sure we soldered it correctly.
    2 Channel: Polk Audio SDA SRS 2.3tl with Clarity CMR caps and Gaia II speaker feet, Atoll IN300 integrated amp, SotM sMS-200 ultra streamer, SotM sPS-500 power supply, and infinite baffle subwoofer with two Fi Audio IB318 drivers.

    HT: Polk Audio speakers: 2.3tl front, CSiA6 center, 500-LS ceiling, RT/FX, RTi8, Monitor 4 rears, and IB subwoofer, Yamaha CX-a5100 AV Preamplifier/Processor, Yamaha MX-a5000 11.1 channel amplifier, Sony XBR55-AE1 OLED TV.
  • F1nutF1nut Posts: 40,631
    Just because something worked before doesn't mean it will today.
    Political Correctness'.........defined

    "A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a t-u-r-d by the clean end."


  • pitdogg2pitdogg2 Posts: 11,479
    Them caps just dwarf the bigger boards.... that's awesome :D
  • BC6BC6 Posts: 72
    It’s definitely not the cable. I tried my CRS cable (which works perfectly on the CRS) and still no SDA effct. The inductor leads might be it. I’ll look at them and post pictures of the back tomorrow.
    2 Channel: Polk Audio SDA SRS 2.3tl with Clarity CMR caps and Gaia II speaker feet, Atoll IN300 integrated amp, SotM sMS-200 ultra streamer, SotM sPS-500 power supply, and infinite baffle subwoofer with two Fi Audio IB318 drivers.

    HT: Polk Audio speakers: 2.3tl front, CSiA6 center, 500-LS ceiling, RT/FX, RTi8, Monitor 4 rears, and IB subwoofer, Yamaha CX-a5100 AV Preamplifier/Processor, Yamaha MX-a5000 11.1 channel amplifier, Sony XBR55-AE1 OLED TV.
  • gmcmangmcman Posts: 1,268
    I would also try a polarity test, make sure all the woofers are firing and in phase.
  • BC6BC6 Posts: 72
    Whew! I fixed it. Gmcman was right about the inductor leads. One of the solders was loose. Thanks to both of you for the help!
    2 Channel: Polk Audio SDA SRS 2.3tl with Clarity CMR caps and Gaia II speaker feet, Atoll IN300 integrated amp, SotM sMS-200 ultra streamer, SotM sPS-500 power supply, and infinite baffle subwoofer with two Fi Audio IB318 drivers.

    HT: Polk Audio speakers: 2.3tl front, CSiA6 center, 500-LS ceiling, RT/FX, RTi8, Monitor 4 rears, and IB subwoofer, Yamaha CX-a5100 AV Preamplifier/Processor, Yamaha MX-a5000 11.1 channel amplifier, Sony XBR55-AE1 OLED TV.
  • la2vegasla2vegas Posts: 2,980
    Glad you got them up and running. Once again the forum gurus prove their worth. Gentlemen you deserve a pat on the back or a kick in the romp, your pick. :D
    2.3TL, 3.1TL, SDA 2B, SDA II, 7B, 7C, 7 series 2, 10B, 5JR+, 5JR, 5A, 4.5, 4, RTA 11TL, RTA 8TL, RTA 8T, LSI9, LSI7 EBONY, LSI7 CHERRY, LSIC, RTI A7, RTI A3, CSI A4, CSI A6, F/XI A4, RTI4. That's all for now.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!