RTA12c Help

Ok next question. I have a Pair od RTA12C speakers I purchased New in 1986-87. 5 years ago I blew 1 Mid range and 1 tweeter. Purchased replacements from Polk. Tweeter is not a SL2000 but the new replacement. Anyway, new problem is the other SL2000 is cutting out when I start to push the power. The speakers are connected to a Carver 300 Watt per channel Amp. I had both coils for the tweeters checked and recapped thru Polk. Any Ideas as to why the cut out? Thanks again Nacki

Best Answer

Answers

  • nackinacki Posts: 4
    Thanks, Will do Monday.
  • NightfallNightfall Posts: 8,221
    I'm not saying problem solved but it's a very likely culprit and cheap.
    afterburnt wrote: »
    They didn't speak a word of English, they were from South Carolina.

    Village Idiot of Club Polk
  • drumminmandrumminman Posts: 3,368
    edited February 2015
    One thing to consider is polyswitches degrade over time (they trip easier), and degrade the sound quality. If you're using high quality amplification and don't drive the amp into clipping you'll get better results by replacing the polyswitch with a Mills resistor. Usually the 1/2 ohm 12 watt brings good results though you can also try 0.22 ohm if you like a bit more high end.

    The other suggestion I have is to get a replacement tweeter identical to the one you bought a few years ago (RD-0194 ?). Mismatched drivers not good.
    "Science is suppose to explain observations not dismiss them as impossible" - Norm on AA; 2.3TL's w/sonicaps/mills/jantzen inductors, Gimpod's boards, Lg Solen SDA inductors, RD-0198's, MW's dynamatted, Armaflex speaker gaskets, H-nuts, brass spikes, Cardas CCGR BP's, upgraded IC Cable, Black Hole Damping Sheet strips, interior of cabinets sealed with Loctite Power Grab, AI-1 interface with 1000VA A-L transformer
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!