12DXi Blown!

nguyendotnguyendot Posts: 3,587
edited January 2012 in Car Subwoofer Talk
I've only had it for like 10 days and the darn thing stopped playing today on the way back from lunch!

PA880 with gain set at 0, boost at 0db, and crossover at 90hz.

Volume on the car was about half. Was playing 6foot, 7 foot by lil wayne.

All of a sudden the bass cut out and all i heard was what i can only describe as sparking across a coil. I got out and looked at the sub, it looked fine, pushed in fine without scraping, and moved freely. All the sound was coming from behind the sub.

Sucks... I don't think I was overdriving it, and it was only being played for about 2 minutes (lunch drive is very short). At first I thought maybe the pole piece separated from the woofer cone, but when I pushed the cone in there was no contact with the pole that sounded like it was moving... OH while typing that I realize that maybe the pole piece did separate and pulled into the subwoofer and isn't coming back out, hence the rattling. The voice coil might just be sitting inside the bottom of the sub and sparking since it is no longer suspended.

What do you guys think? I already called Polk CS - I'm going to swap the sub out tonight for a spare one I have sitting in the garage (Kicker 10) to make sure its not the amp flipping out.

I'm kind of sad, every sub I've ever owned has been played longer, harder, and with more intent than this sub with no problems, and with less power. The PA880 is 500wrms @ 2ohms, this sub is 2 ohms with less power handling. I know I didn't clip it, so I doubt it was underpowering. (I can't stand clipping speakers). I hope this is just a fluke, Polk speakers have always been good to me, you guys know how adamant I am about Polk and this forum :).
Main Surround -
Epson 8350 Projector/ Elite Screens 120" / Pioneer Elite SC-35 / Sunfire Signature / Focal Chorus 716s / Focal Chorus CC / Polk MC80 / Polk PSW150 sub

Bedroom - Sharp Aquos 70" 650 / Pioneer SC-1222k / Polk RT-55 / Polk CS-250

Den - Rotel RSP-1068 / Threshold CAS-2 / Boston VR-M60 / BDP-05FD
Post edited by nguyendot on

Comments

  • VitalVital Posts: 747
    edited March 2011
    Which enclosure did you use? How much internal space?

    Did you take the sub out yet to take a visual at it?
    2008 Nissan Altima
    Kenwood DNX 5140
    Arc Audio IDX and XEQ
    Polk Audio SR6500 active and SR124-dvc sealed
    Polk Audio PA500.4 and PA1200.1
  • nguyendotnguyendot Posts: 3,587
    edited March 2011
    I used the enclosure that comes with it. It's a DXi112 actually.
    Yes I took it out last night, visually fine. Multimeter reads 2.5 ohms so the coil seems to still pass electricity, but it does not move when powered. It moves freely when pushed.
    It didn't scratch when I pushed the cone in the box, but it makes a nice rattling sound when powered (but still no movement). If you push the cone while powered there is no resistance except the surround pulling back.
    Main Surround -
    Epson 8350 Projector/ Elite Screens 120" / Pioneer Elite SC-35 / Sunfire Signature / Focal Chorus 716s / Focal Chorus CC / Polk MC80 / Polk PSW150 sub

    Bedroom - Sharp Aquos 70" 650 / Pioneer SC-1222k / Polk RT-55 / Polk CS-250

    Den - Rotel RSP-1068 / Threshold CAS-2 / Boston VR-M60 / BDP-05FD
  • VitalVital Posts: 747
    edited March 2011
    nguyendot wrote: »
    It didn't scratch when I pushed the cone in the box, but it makes a nice rattling sound when powered (but still no movement). If you push the cone while powered there is no resistance except the surround pulling back.

    I wish i knew the lingo when it comes to subwoofer's components/parts but i don't but on the level of logic that statement is telling me something is physocally disconnected there.
    Do you have warantee on it?
    2008 Nissan Altima
    Kenwood DNX 5140
    Arc Audio IDX and XEQ
    Polk Audio SR6500 active and SR124-dvc sealed
    Polk Audio PA500.4 and PA1200.1
  • nguyendotnguyendot Posts: 3,587
    edited March 2011
    Yup, I got it direct from Polk, they're sending me a new driver and I'll send the old one back.
    Main Surround -
    Epson 8350 Projector/ Elite Screens 120" / Pioneer Elite SC-35 / Sunfire Signature / Focal Chorus 716s / Focal Chorus CC / Polk MC80 / Polk PSW150 sub

    Bedroom - Sharp Aquos 70" 650 / Pioneer SC-1222k / Polk RT-55 / Polk CS-250

    Den - Rotel RSP-1068 / Threshold CAS-2 / Boston VR-M60 / BDP-05FD
  • VitalVital Posts: 747
    edited March 2011
    That would work lol
    2008 Nissan Altima
    Kenwood DNX 5140
    Arc Audio IDX and XEQ
    Polk Audio SR6500 active and SR124-dvc sealed
    Polk Audio PA500.4 and PA1200.1
  • DSkipDSkip Posts: 16,215
    edited March 2011
    Have you tried hooking it up through one of your home amps and running LFE to it? I don't know if you would have anything that could handle the 2 ohm load now that I say that though.
  • nguyendotnguyendot Posts: 3,587
    edited March 2011
    Why hook it up inside? I hooked up my kicker sub and it worked fine.. Had it in there for the week it took to replace.

    So I got the new sub, and the gain is turned to about 1/4, with 0db bass boost on the PA880. I played it today for about 30 minutes at a normal level to test it - I just sound deadened the trunk. While I was doing this the new sub toasted. It wasn't distorting (I know, I was in trunk with it for a bit lol). I don't know what happened, I was delivering even less power this time and the sub started spitting out smoke, then stopped working. TONS of smoke. I've never seen a woofer do this without running an insane amount of power through one.

    I don't get it. I've always had good luck with Polk home audio, but the car subs are not impressing me with their build. I've had Fosgate, Infinity, Alpine Type R's, and Audiobahn subwoofers running insane amounts of power. Now I'm running one sub, in the enclosure designed for it, with the amp made to power it. The amp puts out more power than the sub needs, which is good. What gives? I never expected smoke to come pouring out of the woofer.
    Main Surround -
    Epson 8350 Projector/ Elite Screens 120" / Pioneer Elite SC-35 / Sunfire Signature / Focal Chorus 716s / Focal Chorus CC / Polk MC80 / Polk PSW150 sub

    Bedroom - Sharp Aquos 70" 650 / Pioneer SC-1222k / Polk RT-55 / Polk CS-250

    Den - Rotel RSP-1068 / Threshold CAS-2 / Boston VR-M60 / BDP-05FD
  • DSkipDSkip Posts: 16,215
    edited March 2011
    That's weird. I only mentioned hooking it up inside to see if the 880 just wasn't matched well with it for some odd reason. Perhaps the 880 is faulty and the Polk subs can't handle whatever signal/surge is being thrown its way?


    I've never had issues with any Polk sub, and I've owned about 5 generations of them, dating back to the EXII's. Weird that lightning would strike twice, but there has to be some explanation.
  • nguyendotnguyendot Posts: 3,587
    edited March 2011
    I dunno, the PA880 seems to be made for this sub, it's specs match well. My very small 10" kicker is having no problems with the amp at all.. that's what I don't get.

    I know what distortion is, and I always avoid it. I've never blown a sub like this before, and I've owned a lot. Maybe I should go find the MB Quart amp I used to run, it never had these issues, either.
    Main Surround -
    Epson 8350 Projector/ Elite Screens 120" / Pioneer Elite SC-35 / Sunfire Signature / Focal Chorus 716s / Focal Chorus CC / Polk MC80 / Polk PSW150 sub

    Bedroom - Sharp Aquos 70" 650 / Pioneer SC-1222k / Polk RT-55 / Polk CS-250

    Den - Rotel RSP-1068 / Threshold CAS-2 / Boston VR-M60 / BDP-05FD
  • pentoncmpentoncm Posts: 379
    edited November 2011
    The Dxi 112 in the ported enclosure is rated for 360W RMS. The Polk 880 puts out 800 watts RMS because the 112 is wired internally as 2 ohm. You are sending way too much power to the sub.
    Audison Bit Ten
    Kenwood X595
    Polk MM6501
    Polk MM1240
    Mtx 704x
    Alpine MRX50
  • nguyendotnguyendot Posts: 3,587
    edited November 2011
    pentoncm wrote: »
    The Dxi 112 in the ported enclosure is rated for 360W RMS. The Polk 880 puts out 800 watts RMS because the 112 is wired internally as 2 ohm. You are sending way too much power to the sub.

    Please go back and read all the posts. 1/4 gain with no bass boost, wired at 2 ohms will not drive 800 watts.

    Also, where are you getting 800 watts RMS? The specs say 500w @ 2ohms, 800 DYNAMIC. We don't go by dynamic power here, and that amp won't ever hit 800.

    Also, the 112 is 360w rms, with 720w peak. The subs I got were faulty. Running too much power, if it is clean, will never blow a subwoofer. I am running 1600w rms right now on 2 of the same subs in a sealed box - well over what they're rated at and have not had a problem for over 6 months.
    Main Surround -
    Epson 8350 Projector/ Elite Screens 120" / Pioneer Elite SC-35 / Sunfire Signature / Focal Chorus 716s / Focal Chorus CC / Polk MC80 / Polk PSW150 sub

    Bedroom - Sharp Aquos 70" 650 / Pioneer SC-1222k / Polk RT-55 / Polk CS-250

    Den - Rotel RSP-1068 / Threshold CAS-2 / Boston VR-M60 / BDP-05FD
  • pentoncmpentoncm Posts: 379
    edited November 2011
    nguyendot wrote: »
    Please go back and read all the posts. 1/4 gain with no bass boost, wired at 2 ohms will not drive 800 watts.

    Also, where are you getting 800 watts RMS? The specs say 500w @ 2ohms, 800 DYNAMIC. We don't go by dynamic power here, and that amp won't ever hit 800.

    Also, the 112 is 360w rms, with 720w peak. The subs I got were faulty. Running too much power, if it is clean, will never blow a subwoofer. I am running 1600w rms right now on 2 of the same subs in a sealed box - well over what they're rated at and have not had a problem for over 6 months.

    Hey sorry about that, I went to the tech specs page where it says 800W RMS at 2ohms, that page is confusing.

    Too much power will blow a subwoofer, especially if you are not running a subsonic filter on a ported enclosure. It doesn't appear that the 880 had one. Basically because the enclosure is tuned to about 38Hz, below that frequency the sub will unload and behave as though it is in free air, which could blow the sub if you are listening to low frequency material.

    Even though you have 1600W RMS available I really doubt that you are giving any more than 400W to each sub. For instance if you had everything optimized, and the bass output set to 0db at the HU, and your amp delivers rated power at 13.8V not the 14.4V the amp is rated at, then you would give them 1600W. For instance, if you were to set your HU sub output to -3db , you drop your wattage by half putting you around 800W total, 400WRMS each sub.
    Audison Bit Ten
    Kenwood X595
    Polk MM6501
    Polk MM1240
    Mtx 704x
    Alpine MRX50
  • ipartywhenuhurtipartywhenuhurt Posts: 130
    edited November 2011
    Lol I had the same thing with the same amp pa880 and dxi12 in the enclosure got insurance and spent around 500$u all this about a yr ago and same happened to me lol I was a nub and put yo much power to the sub

    I had the gain all the way down then turned it up just a bit to hear some bass but I always smelled electrical burning smell and I decided to turn the gain up again to the same place and for no reason it Stoped like urs did all same things , I tested it the amp on my friends sub and it was working then used his amp on my sub and nothing so I got it replace then never used it since I didn't know it was droped too two ohms and and I had no clue what Rms was. Long story short the amp is too powerful for the sub. A nice 350 Rms amp would do good

    Ps: im still kinda a nub but not soo much XD
  • nguyendotnguyendot Posts: 3,587
    edited November 2011
    It's not because of too much power... rarely is too much power going to cause a sub to blow out. They burn because of clipping, which causes the pole to go outside the magnetic field, which means it cannot cool itself and then it overheats.

    Thanks for the input, however I would suggest you use a little punctuation in your posts so people don't cringe when they try to read it.
    Main Surround -
    Epson 8350 Projector/ Elite Screens 120" / Pioneer Elite SC-35 / Sunfire Signature / Focal Chorus 716s / Focal Chorus CC / Polk MC80 / Polk PSW150 sub

    Bedroom - Sharp Aquos 70" 650 / Pioneer SC-1222k / Polk RT-55 / Polk CS-250

    Den - Rotel RSP-1068 / Threshold CAS-2 / Boston VR-M60 / BDP-05FD
  • ipartywhenuhurtipartywhenuhurt Posts: 130
    edited November 2011
    Sorry im doing all this on my DROID and it tends to add stuff or autospell wrong, etc
  • cwsmith68cwsmith68 Posts: 434
    edited January 2012
    There are lots of these on ebay for sale cheap! I wondered why so i got one and guess what. It's blown!
    Main system:
    Denon PRA-1500, Denon POA-2400, Denon TU-660, Denon DCD-2560, Denon DVD-2910, Denon DRS-640, Denon DP-30L II w/DL-301 mc cart, BSR EQ-3000, DCM Timeframe 600's
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!