Sound bar quit working. Arc cable not working properly.

Sound bar quit working 2 days ago. At first we thought it was the cable provider. But then we confirmed it is not that because if I go from the box to the tV everything is fine. If I run the arc. Nothing. TV says no signal. I unplugged the arc cable in and out a few times and finally got video but no sound. Plugged and unplugged several more times. Now no video again. Don't understand what the issue could be as we changed nothing. Really frustrating being as this cost me 400 bucks is about a month old.


  • gmcmangmcman Posts: 1,118
    Have you tried another 1.4 spec HDMI cable?
  • mlistens03mlistens03 Posts: 1,407
    gmcman wrote: »
    Have you tried another 1.4 spec HDMI cable?

    This seems to be the most likely candidate to me.
    2 channel
    Speakers: Mission 770 Freedoms
    Integrated amp: Technics SU-v75 and matching tuner
    CDP: Technics SL-PC20
    Cables: Monoprice, Monster, Acoustic Research, and a few generic ones
    TT: Technics SL-3200, direct drive
    Cartridge: Shure M97xE

    Pc gaming setup
    Receiver/amp: Yamaha RX-V665
    Computer: Lenovo g50 (soon to be upgraded to a Dell Precision 690 which is far from stock!!)
    Interconnects: Amazon basics HDMI, Acoustic Research HDMI, Monoprice speaker cables
    Speakers: Boston Acoustics CR75s

    Random equipment on standby:
    Onkyo TX-v940, JBL woofers and tweeters, single Klipsch KG .5, Yamaha guitar amplifier, Peavey Rage 158 guitar amplifier, Kicker comp 12” subwoofer, single Bose 802 series II, a whole bunch of 1”-3” full range drivers, Infinity Crescendo 3007s (on sale), Polk LSi25s
    txcoastal1 wrote: »

    You don't tell her you read the manual, and you tell her you know what the problem is, and you fixed it, because that what men do, fix things
  • jimiallurejimiallure Posts: 5
    Have I replaced the brand new cable that came with the unit i just bought? no i havent
  • jimiallurejimiallure Posts: 5
    ok tried another cable. also tested cable that came with unit on another device and both cables are good. the unit turns on for a second. all the white lights come on then it goes to one amber colored light.
  • jimiallurejimiallure Posts: 5
    talked to polk and they said to download google home and connect to the device using that and that the firmware download would automatically start. got google home, connected tot he device, asked me to use pick a location and i did. then it disconnected from the unit and asked me if i wanted to connect and set up unit again. i said yes and now it wont connect.
  • jimiallurejimiallure Posts: 5
    edited June 27
    now google home wont even read my device? smh
  • KennethSwaugerKennethSwauger Moderator Posts: 6,537
    Sorry for the problem, I'll ask a friend at Polk to contact you via email.
    "And the house you live in will never fall down
    If you pity the stranger who stands at your gate" G.Lightfoot
  • KennethSwaugerKennethSwauger Moderator Posts: 6,537
    From what I've been told Google Home has been down since yesterday. That could account for your issue.
    "And the house you live in will never fall down
    If you pity the stranger who stands at your gate" G.Lightfoot
  • WhereYouWhereYou Posts: 9
    Have you tried to use the HDMI converter to connect it with the TV and soundbar?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!