blown fuse

Systems
Systems Posts: 14,872
edited January 2003 in Car Subwoofer Talk
can somone tell me why my amp fuse kept burning out on me? i install a new wiring system from that day on everytime i insert the fuse into the fuse holder, it got blown up. wat can i do to correcdt his source of error.
thanks
Testing
Testing
Testing
Post edited by Unknown User on

Comments

  • PoweredByDodge
    PoweredByDodge Posts: 4,183
    edited January 2003
    if the fuse is blowing before you even turn the system on, then you have a bad short somewhere... trace your lines for kinks, screw punctures, etc etc.

    if the fuse is blowing once you turn on system on, you need to determine---

    1- if its the proper size fuse
    2- if the amp is damaged (or or other components on that line)
    3- if any capacitor you might have is damaged.
    "With your own attitude it is hard to survive here... But who gives a damn, we are here to change the world, and we dont need a password for that."
    - Anurag
  • Systems
    Systems Posts: 14,872
    edited January 2003
    i tried it with a different amp , same brand with lower wattage, and it works find, but the other ones, the fuse burn before the system is turned on. that means it is not the wiring problem and its is not the amp problem according the the previous threat becuse the system is not turn on.
    i really need an answert to this question, thanks
    tdo
    Testing
    Testing
    Testing
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!