Wire Smell

dc954dc954 Posts: 3
I have had my RT2000i's for about a month now and love them, however it seems as though there is a electrical smell coming from them? I have check voltages in my new house and that is okay and verified the wiring, "14guage" monster cable. My receiver is 110 X 5. What else can I look at?

Don:):o :o
Post edited by dc954 on

Comments

  • joe logstonjoe logston Posts: 882
    edited May 2002
    is the rt2000i a powerd tower, it might be the amp got hot, unplug the amp and if the smell gose away it the amp.
    . rt-7 mains
    rt-20p surounds
    cs-400i front center
    cs-350 ls rear center
    2 energy take 5, efects
    2- psw-650 , subs
    1- 15" audiosource sub

    lets all go to the next ces.
  • dc954dc954 Posts: 3
    edited May 2002
    Yes, they are powered. Are you speaking of the receiver and/or the power to the speaker itself.
  • joe logstonjoe logston Posts: 882
    edited May 2002
    the interal amp of the speakers , where is the smell coming from
    . rt-7 mains
    rt-20p surounds
    cs-400i front center
    cs-350 ls rear center
    2 energy take 5, efects
    2- psw-650 , subs
    1- 15" audiosource sub

    lets all go to the next ces.
  • joe logstonjoe logston Posts: 882
    edited May 2002
    if the smell is coming from the amp you might have blowin it, i dont know if there is a fuse on the internal amp or not , maybe someone else will know that, hey guys help out
    thanks
    . rt-7 mains
    rt-20p surounds
    cs-400i front center
    cs-350 ls rear center
    2 energy take 5, efects
    2- psw-650 , subs
    1- 15" audiosource sub

    lets all go to the next ces.
  • joe logstonjoe logston Posts: 882
    edited May 2002
    be sure to check wire connections to go through all the wires and double check every thing for shorts or wires hook up wrong
    . rt-7 mains
    rt-20p surounds
    cs-400i front center
    cs-350 ls rear center
    2 energy take 5, efects
    2- psw-650 , subs
    1- 15" audiosource sub

    lets all go to the next ces.
  • cgravilcgravil Posts: 101
    edited May 2002
    I may have an answer. New electronic components have a "smell" about them as they warm up. This is VERY prominent on newly built computers, it is just the silicon burning itsself in. I had it in my home theater for about 3 weeks because of my new TV and my new reciever. It is still here but not as much. It will go away soon.

    I find it similar to that new car smell, but for electronics . Just my idea on this, but I could be completely off base
    The probibility of someone watching you is directly related to the stupidity of the action in question.:eek:
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!