What the, a brittle rubber surround?

I picked up a set of Polk RTA 11Ts the other day. The Cabinets and drivers were in great shape but bottom passive woofer is shot. The rubber surround is like an egg shell. Its dry and brittle to the touch. Any ideas what would of caused this?
Speakers: TL Monitor 10s, RTA 11TLs, Fortes, Thiel CS 1.2
Amplifiers: ]Ashly FTX 2001 III, Dynaco ST-70, DIY F6
Pre: Adcom GFP 750, Aikido Tube Pre

Comments

  • pitdogg2
    pitdogg2 Posts: 19,235
    Aggressive cleaners, heat from furnace, sunlight.....

    Thinking out loud
  • audioluvr
    audioluvr Posts: 3,621
    Armor-all
    Cambridge Audio 851N Streamer/DAC
    Belles 21A Pre modded with Mundorf Supreme caps
    B&K M200 Sonata monoblocks refreshed and upgraded
    Belles 350A Reference modded with Mundorf Supreme caps
    Polk SDA 1C's modded / 1000Va Dreadnaught
    Wireworld Silver Eclipse IC's and speaker cables


    There is about a 5% genetic difference between apes and men …but that difference is the difference between throwing your own poo when you are annoyed …and Einstein, Shakespeare and Miss January.

    by Dr. Sardonicus
  • bored184
    bored184 Posts: 264
    Interesting, being hung up I wonder if the one with the broken passive was hung near a heater. If it were chemicals I'd assumed the other drivers would of been affected.
    Speakers: TL Monitor 10s, RTA 11TLs, Fortes, Thiel CS 1.2
    Amplifiers: ]Ashly FTX 2001 III, Dynaco ST-70, DIY F6
    Pre: Adcom GFP 750, Aikido Tube Pre