polk ds-1 sub light?

i have an older polk DS-1 SURROUND SYSTEM,and it wont work,should the power light on the sub be red or green? Mine is showing red.
Please help!!

Comments

  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Hello,
    There is a system reset: from the front panel of the controller push these buttons simultaneously, "save preset", "clear" and "preset up" the display should read "default". Then turn the system off and then on and you should be fine, you will have to go through the system balancing procedure.
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • I tried that,no luck. no sound and the sub light is still red :(
  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Hello,
    The amplifier in the subwoofer powers all the speakers, that's why there's no sound. The last thing you can try is to remove the DB25 connecting cable from both the processor and the subwoofer then carefully reinstall the cable, making sure the connections are seated properly as you tighten the thumbscrews.
    If this still doesn't work contact Polk's CS department at either 1-800-377-7655 or via email to [email protected]
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • yea,nothing is helping,worked great last time it was hooked up,its been setting for about a year,no idea what happened.Im gonna call the service dept.But cost in shipping and cost to fix it will most likely make it a lost cause.What new product is compariable? This thing sounded great!!! Thanks everone
  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Hello,
    I'm sorry it's not working. Shipping might be less than you think, Polk can help remove the amp from the sub enclosure (if that's necessary) and just ship it rather than the complete sub.
    A phone call will be good.
    Cheers, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • so,do you think its in the sub instead of the "reciever" unit?
  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Hello,
    At this point it could be either component, the controller or the amplifiers. If I were to venture a guess I would think the amp, but it's just a guess.
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!