Can't connect my Omni s2

I already trying for the last 2hours to connect my omni S2 Speakers

I have an Apple Airport router and Iphone
No matter what I did it's not connected.

I'm always get the 'No Device found' no matter what I did.

Help! I'm about to return them

Comments

  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Hello,
    Welcome to Polk's forum, I'm sorry you're having a problem. Polk has a customer service department dedicated to supporting the Omni project. Their phone number is 1-800-377-7655 available Monday through Friday. I'll try contacting one of the team members directly and see if I can get you some help sooner.
    It's a great product, hang in there and we'll get you enjoying it.
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • Got my Omni 2 today and have the same problem. Have been a network engineer for 20 years, understand wifi and connectivity. Hard reset speaker 6 times, went through install process repeatedly. 30 minutes on phone with your support - every time, and from two different devices iPhone 5S and iPad 3, no matter what, "No Device Found". So I'm returning it to Best Buy in the morning. Polk support folks- if you had better support or FAQ, maybe this speaker could be made to work. Shame on you - I WORK Monday-Friday during business hours. If you can't support us in the evenings, you'll have to take returns. What's cheaper - after hours support or product returns because support is not available? A shame, want to like this product, but it has never made a sound.
  • LibertycLibertyc Posts: 912
    Welcome to the club.

    I'm using an S2 with my Android tablet. It basically set itself up after I installed the Polk app.

    What color is the light on the front of the speaker?
  • LibertycLibertyc Posts: 912
    Polk has excellent customer service and support. I'm not very familiar with IOS but there are members here that have the S! and use Apple devices.

    I know it must be frustrating that it will not connect, but after its set up you will be very happy with the Omni system.
  • Thanks Libertyc - there's no light on the front, unless I press a button, then amber. The blue light on back is solid blue (not blinking).

    The support guy I worked with had me uninstall/reinstall the Polk Omni app, no help. He tried to contact a support person on the app, but just got voice mail.

    Apple IOS is everywhere, right? It's possible it's just a defective unit.

    I want to be happy!
  • LibertycLibertyc Posts: 912
    When I first power my S1 on the light is flashing yellow, then turns solid yellow. When I open the app the light turns solid white.

    Maybe this link will help you: http://wireless.polkaudio.com/preferred/

    Its says they have evening / weekend support.
  • LibertycLibertyc Posts: 912
    Here is the quick start guide to the S! http://wireless.polkaudio.com/pdfs/Omni_S2.pd

    Hopefully you will soon get the problem solved very soon.

  • Thanks for being so helpful! When powered on, the light blinks yellow, then goes out and stays out. The blue light on the back blinks, then goes solid, which should indicate wifi connection. Phone just won't find it.

    Went to the web link - too late to call again tonight, but will try first thing tomorrow.

    Thanks again....
  • LibertycLibertyc Posts: 912
    Welcome

    Yes solid blue on back indicates a connection. When I start the Polk app the light on the front turns solid white. Seems like an app problem.
  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Thanks for the assist, Libertyc!
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • Just got off phone with Polk Audio support - turns out the router I have for DSL + wifi, the Actiontec C1000A from CenturyLink (phone co here). Said that the C1000A router is not capable of completing the connection with the Polk Omni application. Incompatable. Either replace the C1000A, or put a second wifi router downstream with a separate subnet for the Polk Omni app to be able to 'see' the speaker.
  • I solved my problem.

    Too bad there is no FAQ. It took me over 3 hours! and I'm a techie guy

    I figure that maybe the name of my network is causing the problem.
    my network name had the <> symbols so I changed it to a simple and shorter one
    and only then it connected.

    Then It took me ages to update each speaker. The process was long and halt a few times. I had to do an update for one speakers 3 or 4 times.

    Currently all good.
  • LibertycLibertyc Posts: 912
    Good to hear.

    How did you update each speaker?
  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Hello,
    I'm glad there was some resolution on the problems. Polk's wireless support guys are available at: 1-800-638-7276 M-F 9 until 9 and weekends 10 until 6.
    Best regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • I'm having the same issue. The device is already in the network but when I go to settings/wifi/, i can not see PLAY-Fi or the polk omni device. Is the APP working?
  • KennethSwaugerKennethSwauger Moderator Posts: 6,846
    Hello,
    Welcome to Polk's forum, I'm sorry you're having a problem. I'm not sure what Polk's helpline schedule is this long weekend, but give a call to the number given in the posting above yours.
    Regards, Ken
    "They thought we were too loud, but shoot, I had four army blankets folded over my amp, and the volume level was on 2. I'm used to playin' on 10!" S.R.V.
  • I had the same connection problems between mi Omni SB1 and mi WiFi.

    I have an Airport Extreme (2014 model) as a router, and neither from my iPhone, my wife's MacBook pro or my windows laptop was able to make them detect the SB1 and connect.

    I have 15+ years in IT, so routers, protocols, passwords, channels, etc is something I am pretty much familiar with, and yes I restarted everything more than once, and that included the SB, router, Phone, Laptops, unplugging the SB for a couple of minutes as well.

    I tried to set it up using both, the POLK application and the Play-Fi application on the mobile and mac, and the Play-Fi on the windows laptop. Same result on all of them, unable to connect or unable to detect the SB.

    Sometimes I was able to see the SB listed as another wifi (something expected, according to the POLK app set up process), but I was not able to connect to it (as also requested on the setup process), I just kept receiving a "connection unsuccessful" message, some others it just won't appear listed at all on the available WiFi list.

    After 2 hours of several attempts, this is what I did, but since I did everything at once, I am not sure what fixed the problem.

    1. I set different names for my 2.4ghz and my 5 ghz networks (they used to be named the same), not sure if the SB1 can detect 5 ghz, but since it says dual band on the specs, I just wanted to make sure I had no confusions with that

    2. Restarted everything again.

    3. Tired of not being able to listen to my SB, I just plugged an AUX cable and plugged my ipod. This is the step that seemed to "awake" the SB, because when trying to set up the WiFi again, it worked without problem, just by executing the same steps I had tried over and over for the last couple of hours. I listened to a couple of songs, checked the subwoofer was ok, as well as the remote functions, then...

    4. I tried for the "n" time to set up the wifi. I pressed the Wifi button on the top of the SB (if you press this button for 4 seconds, you will hear a beep, that means the WPS discovery mode is on, if you wait 8 seconds you will hear a second beep, that is the manual mode, both of them are expected to work fine). After the first beep (WPS mode on), I used the "add wireless clients" option on my Airport Extreme, and my SB connected without problems to my wifi (I had tried this same option before with no luck), both the POLK app and the Play-Fi application detected it without problems.

    Now, after connecting successfully to my SB, the POLK app told me that an update was available for my SB, I accepted the update, Steps 1 and 2 of the automated update process worked OK, but when executing Step 3, it send a message of "unable to connect to the SB", I noticed the SB was off, not sure if because as part of the update process it tried to reboot but stayed off, or if because of not playing music for more than 5 minutes it automatically shut off, in the middle of the update process.

    I turned the SB on again, press the WiFi button, the SB connected without problems again, executed the update again, it worked fine, and so far I have not had more problems with my SB.

    I hope this information is somehow helpful for someone else.

    Regards
    Oscar
  • My apple products wouldn't connect it. (I tried for 2 hours)
    I dug out my old kindle fire downloaded the app and was up and running.
    After the kindle connected the apple products also work
    Try an android device if available.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!