Last Active


  • breischaft
    breischaft wrote: »
    I have 2 Omni S6 Speakers, in the same room. They've been working as a 'stereo pair' for about a year. last week, one stopped playing music. both show connected still to the app on the phone.

    I can unpair them and select them both. App shows that they are both connected. lights are on on both. volume controls work on both. only one plays music. I can switch the primary speaker to either one and it plays, but the secondary stops.

    getting same results using DTS iPhone app and the Polk Omni iPhone app. Same when switch to iPad.

    I don't know what else to try. I feel like I've done all the hardware combinations I can think of.

    breischaft wrote: »
    I've now tried with the other 6 Polk Omni devices we have. same story. it used to be I could play throughout the house at one time, using the app and the volume buttons to adjust individual speakers. now, only one will play at a time.

    Interestingly, I can play one Music Service to the Left S6 from iPad while I play another Music service to the Right S6 from iPhone. just can't get one service from one device to multiple speakers.

    What's up with that? Customer Service, please help!
    March 8
  • Tommy_B
    Had the Magnifi Max SR for around a month and from day one the wireless subwoofer has a constant low crackling sound. Supplier suggested updating to latest software (79) using google home app. No difference. Tried using hdmi arc and optical. No difference. Tried plugging into different power sockets (even in different rooms). No difference. My supplier has now said that Polk are aware of the problem and should fix it at sometime in the future with a new software update but don't know when?! This has become such a problem I have just unplugged the sub. A real shame because the sound is great from this system. If this ain't fixed soon I'll be returning it.
    Any ideas?
    March 6
  • Rosaski
    Hello, do you know when a firmware update for the Magnifi Max SR will be released next.

    I am getting high pitched popping (short noises) from the SR speakers and the dialogue speaker doesn't seem to get much louder when volume is increased?

    Thank you,
    February 19

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


100 CommentsSecond Anniversary25 Likes5 Agrees5 LikesFirst AnswerName Dropper10 CommentsFirst AnniversaryPhotogenicFirst Comment