Oppo 203

Went to watch Hacksaw Ridge on my new 203, and fifteen minutes in it started going into mute, saying it's not supported with this player. Never did it on my 103D. Anyone have this happen to them?
Panny 8000 project
Oppo 103D
Fronts- Monitor 70's
Upper fronts- Monitor 30's
Surrounds- Monitor 50's
Backs- Monitor 40's
Center-CS 350
Sub- SVS PB 2000
Onkyo 607[back up]

Comments

  • pitdogg2pitdogg2 Posts: 10,227
    Call oppo see if it is a known problem and if there is a firmware update for it.
  • EmlynEmlyn Posts: 2,079
    In the past I usually have had to update the firmware when first receiving an Oppo product.

    Was it the 4K disc version or a Blu Ray disc? I have played the 4K version of Hacksaw Ridge on my 205 with no issues, but not the Blu Ray that came with it.
    1. Polk LSiM707, 704C, 703; Dual SVS SB2000 subwoofers; Marantz SR7011 receiver; Parasound A23 amp; Oppo 205; Toshiba HD-DVD Player; Sony 65" 4K TV; FIOS; PS Audio Power Plant Premier; MIT S2 cables
    2. JM Labs Electra 920.1; Parasound JC2 Preamp; Sonic Frontiers Power 2 amp; Sony HAP-Z1ES; Oppo 105D; Music Hall MMF7 and Acoustech phono pre; PS Audio P1000; MIT S1 Cables
    3. Polk LSiM703; Pioneer Elite SC97 receiver; Oppo 203; Squeezebox Touch; MIT S3 cables
  • woodhead 2woodhead 2 Posts: 348
    They sent me instructions on how to fix it. Works fine now. Thanks
    Panny 8000 project
    Oppo 103D
    Fronts- Monitor 70's
    Upper fronts- Monitor 30's
    Surrounds- Monitor 50's
    Backs- Monitor 40's
    Center-CS 350
    Sub- SVS PB 2000
    Onkyo 607[back up]
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!