T-30 Tinny Sounding

My first post!!

I have recently purchased a T-30 as well as two sets of T-15's. These are all connected to a Denon Atmos surround receiver. I'm slowly putting my system together and currently I have the T-30 center channel and two of the T-15 hooked up for front-L and front-R.

Something I noticed from the start though is that the T-30 sounds very "tinny" for lack of better term. It has a tweeter and two mid-range drivers in it and it sounds like it is ONLY using the tweeter. Being somewhat a newbie when it comes to higher-end surround setups I thought perhaps it was supposed to be like that. I turned up the center channel manually to compensate but it was never really right. It's been a couple months now.

I decided to open the second set of T-15's and start hooking those up for rear channel this morning and for the heck of it I plugged one of those in, in place of the T-30 and WOW! What a difference! The sound is MUCH more what I'd expect to hear!

Set all default levels to factory on the amp and it still sounds great.

[frantically looking for a switch or some setting on the T-30 to "fix" this, but no luck]

Hooked the T-15 back up.....sounds great.

Am I missing something or is this a bad T-30 somehow?

Thanks for any help!

Comments

  • KennethSwaugerKennethSwauger Moderator Posts: 6,624
    Hello,
    It sounds as though the two mid-range drivers are either not connected to the speaker's crossover or are damaged and not functioning. The first thing to do is contact the store (or online company) and ask about service or exchange. If this doesn't solve the problem contact Polk at 1-800-377-7655 select option 1, have the speaker's serial number available when you call.
    "And the house you live in will never fall down
    If you pity the stranger who stands at your gate" G.Lightfoot
  • Hello,
    It sounds as though the two mid-range drivers are either not connected to the speaker's crossover or are damaged and not functioning. The first thing to do is contact the store (or online company) and ask about service or exchange. If this doesn't solve the problem contact Polk at 1-800-377-7655 select option 1, have the speaker's serial number available when you call.

    Thank you. I bought them at Fry's. I'll have to see how long ago and if the store will help....
  • KennethSwaugerKennethSwauger Moderator Posts: 6,624
    You're welcome.
    Most likely if you didn't buy a service policy they will refer you to Polk for service.
    "And the house you live in will never fall down
    If you pity the stranger who stands at your gate" G.Lightfoot
  • You're welcome.
    Most likely if you didn't buy a service policy they will refer you to Polk for service.

    I can live with that and it may be the option, but they are a big store and I buy a lot from them. Sometimes they go above and beyond. I realize that I didn't even open this thing for a couple months so it's not on them...if I had discovered this the day or week I bought it, it would be a no-brainer.
  • UPDATE: I called Frys.com and they said "sorry, can't help you because it's been over 30 days".

    Went to the store and they said "sorry.....you bought it from us, but online....so we can't help here in the store."

    Called Polk directly and although I had to wait 20 minutes to get a human, he was going to ship me new drivers for my speaker for self-installation. I had no idea I could open it without voiding the warranty and he said it's no problem with Polk in the case of audio components. (try doing that with Dell on a laptop....;))

    So I opened the case and the wire that leads from one 5 1/4" driver to the other was disconnected. Since the drivers are in series, doing this basically disconnects the two mid-range speakers entirely, which is the "tinny" symptom I was getting....the tweeter was the only speaker connected.

    Reconnected that wire, tested and voila....it works!!

    Yay! Thanks for the feedback!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!