Woofer stuck in standby psw505

Hello,
My 2 year old subwoofer stays in standby mode(red light). I tried hooking up a different reciever and wired it via speaker wire instead of the rca input. It stays with the red light on. Any ideas? Thanks

Comments

  • FestYboyFestYboy Posts: 2,871
    Have you tried the "always on" position to eliminate the auto detect feature?
  • Yes, I have flipped the switch to any of the three positions and still no change in the red light or bass from the speaker.
  • KennethSwaugerKennethSwauger Moderator Posts: 6,648
    Hello,
    It would be best to contact Polk at 1-800-377-7655 select option 1 and have the serial number when you call.
    "And the house you live in will never fall down
    If you pity the stranger who stands at your gate" G.Lightfoot
  • OK I called and they are sending me a replacement amp. When they email you with the information needed( Serial # invoice etc) do you just reply to that email with the information? Will a screen shot of the email invoice from Newegg suffice?

    Thanks
  • KennethSwaugerKennethSwauger Moderator Posts: 6,648
    I believe that would be correct.
    "And the house you live in will never fall down
    If you pity the stranger who stands at your gate" G.Lightfoot
  • Ok Thanks I will let you know if the replacement part solves the SW problem.
  • Polk sent me the replacement amp and the woofer fired right up find. I hope the replacement part doesn't have the same life as the old. Thanks for your help
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!