Magnifi Max sound bar amber light blinking

the speaker is not responding to anything. i have pulled the plug, pressed the reset button, the subwoofer sync button, the mute button, the input button. nothing is working. how can i get it to start working again?

Comments

  • KennethSwaugerKennethSwauger Moderator Posts: 6,620
    Hello,
    The best thing to do is call Polk at 1-800-377-7655 select option 1 and have the serial number handy when you call.
    "And the house you live in will never fall down
    If you pity the stranger who stands at your gate" G.Lightfoot
  • geedeegeedee Posts: 4
    ok thanks. called them. they said sound bar has gone into PROTECT MODE for some reason.

    It is very unsettling that month old $500 sound bar has become useless without extensive use.
  • mlistens03mlistens03 Posts: 2,141
    geedee wrote: »
    ok thanks. called them. they said sound bar has gone into PROTECT MODE for some reason.

    It is very unsettling that month old $500 sound bar has become useless without extensive use.

    Something probably just failed. Tends to be the norm with electronics, unfortunately.
    Did you push it hard before it started? That could have caused a short in the subwoofer driver and caused the amp to go into protect.
    Not Tom, or Trey, or Jim
    NAD C352
    Monitor Audio Radius R90’s/Mission Freedom 770 IV
    BJC speaker cables, generic RCA’s, one homemade power cable, because that’s going to do any good with the rest of the generic ones.
    Technics SL3200 turntable and a Shure M97xE phono cartridge
    Velodyne VA-907 subwoofer
    Lafayette LR-1100 acting as a tuner and phono.
    I've always thought the goal of high end audio was not to have your neighbors bang on the wall and say, 'Turn that darn music down' but to have your neighbors bang on the wall and say, 'Tell your friends to go home and you can practice later this week'.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!