Magnifi Mini - Red Light Flashing Non-Stop

A couple of weeks ago I set up my Magnifi Mini. Everything worked fine. Connected it to the Google Home app at night, and it still worked fine right after connecting it. The next morning, the Mini wouldn't turn on at all. So I unplugged the unit for 20 seconds and plugged it back in. The middle light on the front of the unit started flashing red non-stop, and the unit won't respond at all. Power cycling or trying the wifi reset does nothing.

Contacted Polk support via email over 2 weeks ago, and no response. Calling isn't really an option since I work during their hours. Anybody have any ideas??

Comments

  • KennethSwaugerKennethSwauger Moderator Posts: 6,580
    Hello,
    I'll ask someone at Polk to contact you via email.
    "And the house you live in will never fall down
    If you pity the stranger who stands at your gate" G.Lightfoot
  • I’m having the exact same problem! I connected my unit up last night, and couldn’t get anything but a flashing amber light this morning. If I can’t get help, I’m gonna have to take it back.
  • After reaching out to Polk, they replaced the unit under warranty. New unit works perfectly. Thank you, Polk!
  • brerojasbrerojas Posts: 1
    I've been having the same issue... I turn it on, and it works for maybe 5min, then it disconnects, and I get a red blinking light and now it won't connect anymore. I've barely had it for a couple months. :-/
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!