Magnifi Max SR surrounds issue

Just putting this out there to see if anyone is having issues with the SR surround speakers. I currently am having one of them that is "popping" every now and then. Anyone else? and is there a fix?

Comments

  • RosaskiRosaski Posts: 7
    Yes,

    I have the Magnifi max sr and have noticed high pitched noises(poping) coming from the surround sound speakers.

    Seems to happen more when playing content with video(s)
  • Glad to know I'm not alone. I can't reproduce it because it just happens intermittently.

    What about delays when switching sources (thinking 5-8 seconds)? Or even sound not coming through after a source switch and needing to reboot or fiddle with things to get sound back on?
  • KennethSwaugerKennethSwauger Moderator Posts: 6,192
    Hello,
    I'll bring this to Polk's attention.
    "Listen to them, the children of the night. What music they make", Bram Stoker
  • RosaskiRosaski Posts: 7
    Hello,
    I'll bring this to Polk's attention.

    Thank you.

    Also FYI the sub does have a low scratchy type noise at ver low volumes. not as bad as the SR high frequency noises though.
  • RosaskiRosaski Posts: 7
    henninge wrote: »
    Glad to know I'm not alone. I can't reproduce it because it just happens intermittently.

    What about delays when switching sources (thinking 5-8 seconds)? Or even sound not coming through after a source switch and needing to reboot or fiddle with things to get sound back on?

    Forgot to mention it seems to happen more with Video content.

    I have noticed that I need to reboot it sometimes for everything to sync up properly
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!