My Polk Magnifi Mini has not worked right since I received it.....cuts out constantly!

I ordered the Magnifi from Crutchfield, and since installing it has constantly dropped the sound if we change input sources, when we initially turn tv on, and every time I have to go through this ridiculous series of turning tv off, Magnifi off, power tv up, power Magnify up, hit optical, and the cinema button for it to sporadically work. This seems to be a known issue by all the same problems listed in various forms on this site. Crutchfield sent me another optical cable but now it's not working at all. I read that it may need to download a firmware update, but how would this happen if it's just plugged into back of tv?
The sound was great the few times it worked, but over all this is garbage. Is Polk responding to anybody about this known issue?! I heard great things about Polk and was excited to buy this, but looks like I should have bought another brand.

Comments

  • Viking64Viking64 Posts: 1,489
    There are a few threads about this item in the "Troubleshooting" forum.
  • Viking64Viking64 Posts: 1,489
    Viking64 wrote: »
    There are a few threads about this item in the "Troubleshooting" forum.

    But don't go there and mouth-off to the moderators. That's just bad form, I must say.

    c1zc6o7eosq9.jpg
  • KennethSwaugerKennethSwauger Moderator Posts: 6,192
    Hello,
    Welcome to Polk's forum. It would be best to contact Polk at: 1-800-377-7655 select option 1 and they'll get you squared away.
    Regards, Ken
    "Listen to them, the children of the night. What music they make", Bram Stoker
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!