Polk Surroundbar 2000 red light blue light and green light alternate blinking

Hi there,
I have a Surroundbar 2000 and it was working fine for several months and now it wont do anything. No sound will come out and the red light on the side of the power button will come on and then turn off. When it turns off a green light comes on beside the power button and the blue light beside the source button also comes on. Then repeats the cycle?
Any help would be greatly appreciated!!!!

Comments

  • KennethSwaugerKennethSwauger Moderator Posts: 6,065
    Hello,
    Welcome to Polk's forum. It's best to contact Polk's CS department at: 1-800-377-7655 select option 1. Be sure and have the unit's serial number handy when calling. This is a busy time of the year, so be patient.
    Regards, Ken
    "Passion is inversely proportional to the amount of real information available", G. Benfield
  • ArkydadArkydad Posts: 2
    Thanks I will try that....
  • mybikemybike Posts: 3
    I also have a surroundbar 2000 that stopped working. I have unplugged the power supply,waited approximately 5 mins , plugged unit back in,still no sound. All lights are working on too, it responds to the remote, just no sound ?
    Serial# AM 120113649 any ideas ?
  • KennethSwaugerKennethSwauger Moderator Posts: 6,065
    Hello,
    It would be best to begin with Polk CS at 1-800-377-7655 select option 1, keep in mind the phone lines will be busy after the weekend.
    Regards, Ken
    "Passion is inversely proportional to the amount of real information available", G. Benfield
  • mybikemybike Posts: 3
    I haven't heard from CS called yesterday. Are there any things I can try while I am waiting to hear from Customer Support.?
  • mybikemybike Posts: 3
    I finally got thru to CS Dept. My sound bar is shot. It's a outdated model.
    Thanks for the help. !
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!